Bug 139124 - DOCX file contains image; image is displayed but not printed
Summary: DOCX file contains image; image is displayed but not printed
Status: RESOLVED DUPLICATE of bug 129085
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.beta1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-12-21 11:44 UTC by Grantler
Modified: 2021-03-11 13:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
described file containing problem image (115.27 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-12-21 11:47 UTC, Grantler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Grantler 2020-12-21 11:44:06 UTC
Description:
A docx file from a colleague includes 2 images. The first image (page 1) is the problem:
- On OpenOffice 4.1.8 it is not displayed.
- On LibreOffice Writer (6.4.7.2 and 7.0.3.1) it is displayed but can't be printed (print preview does not display it; print-out does not contain it).

What I found out (LibreOffice 7.1.0.0beta1) is:
- The image is anchored to character.
- The anchoring symbol is located far outside the text area.

Workaround: 
- Save the image as a file.
- Delete the problem image in Writer document and import file, then you have to crop it; apply wrapping.

Steps to Reproduce:
see description

Actual Results:
open file and check print preview

Expected Results:
image is missing in print preview


Reproducible: Always


User Profile Reset: No



Additional Info:
image should be displayed in print preview and then the print out should contain this element
Comment 1 Grantler 2020-12-21 11:47:03 UTC
Created attachment 168376 [details]
described file containing problem image
Comment 2 Grantler 2020-12-21 18:52:39 UTC
*In description there was written:*
------------------
Steps to Reproduce:
see description

Actual Results:
open file and check print preview

Expected Results:
image is missing in print preview
------------------

This is misleading.

The image still exists in the print preview. But if you start the print dialog, the preview of the print dialog does not display the image as well as the print-out does not do that.

Sorry for my inaccuracy!
Comment 3 Telesto 2020-12-22 09:49:11 UTC Comment hidden (obsolete)
Comment 4 Telesto 2020-12-22 09:52:41 UTC Comment hidden (obsolete)
Comment 5 Telesto 2020-12-22 09:55:44 UTC
Found in
Version: 7.0.0.0.beta1+ (x64)
Build ID: 2891e91a513520d68ea2b8c59c14335861a15253
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

not in oldest of 7.0 repro
Comment 6 Justin L 2021-01-26 09:51:49 UTC
[@Telesto - I have seen you doing bibisects before. Why aren't you bibisecting every issue before you respond?]

I can confirm that the gingerbread men disappear from the first page in 7.2+.

I used bibisect-linux-64-7.0 to bisect. This problem can also been reproduced by looking at the thumbnail generated, so my process was to open the document, and then close it - and look at the thumbnail in the start center. That pointed to (and was confirmed by a printout) author Miklos Vajna on 2020-05-13 21:29:25 with commit 2abe9837deee3823c7928a76b5b2f94f1464f1a3
    DOCX import: fix interaction between the crop and the wrap polygon of images

https://cgit.freedesktop.org/libreoffice/core/commit/?id=2abe9837deee3823c7928a76b5b2f94f1464f1a3

This patch was backported to LO 6.4.
Comment 7 Justin L 2021-01-26 11:06:25 UTC
My amateur guess is that this is related to vcl/unx/generic/gdi/salbmp.cxx:158: 32-bit images not supported, converting to 24-bit.

pCorrected size H[41346]W[25964] to crop[1363][2719][6092][6143]


P.S. The "look at the thumbnail in start menu" trick doesn't work any more in master. That was fixed by author Luboš Luňák on 2020-10-12 15:13:17 with
commit 59cca1a28df4cdc94450d68cc1e247a8fb5ff6f3
render document thumbnail directly to bitmap, without metafile

But I don't think that will help at all with fixing this bug.
Comment 8 Xisco Faulí 2021-03-11 13:08:40 UTC
This is fixed with https://gerrit.libreoffice.org/c/core/+/112340.
Closing as duplicate of bug 129085

*** This bug has been marked as a duplicate of bug 129085 ***