Bug 139211 - Opening DOCX with arabic text slow (lots of xml parsing)
Summary: Opening DOCX with arabic text slow (lots of xml parsing)
Status: RESOLVED DUPLICATE of bug 120351
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx, perf
Depends on:
Blocks: DOCX-Opening RTL-Arabic
  Show dependency treegraph
 
Reported: 2020-12-24 15:42 UTC by Telesto
Modified: 2021-02-19 16:24 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (8.61 MB, application/vnd.oasis.opendocument.text)
2020-12-24 15:42 UTC, Telesto
Details
Example file (329.61 KB, application/vnd.oasis.opendocument.text)
2020-12-24 15:45 UTC, Telesto
Details
DOCX from example (472.28 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-12-24 17:18 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-12-24 15:42:35 UTC
Description:
Opening DOCX with arabic text slow (lots of xml parsing)

Steps to Reproduce:
1. Open the attached file
2. Save as DOCX
3. File reload

Actual Results:
30-45 seconds

Expected Results:
15 seconds 


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 315c7570c4a72f4c834086082825533b1e50d1bf
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-12-24 15:42:56 UTC
Created attachment 168469 [details]
Example file
Comment 2 Telesto 2020-12-24 15:45:03 UTC
Created attachment 168470 [details]
Example file
Comment 3 Telesto 2020-12-24 15:49:53 UTC
Also in
3.3.0
Comment 4 Roman Kuznetsov 2020-12-24 17:17:44 UTC
confirm in

Version: 7.2.0.0.alpha0+ (x64)
Build ID: cb22636a56b35d4e118446cc3c9fe606db6f46b0
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: CL
Comment 5 Roman Kuznetsov 2020-12-24 17:18:17 UTC
Created attachment 168471 [details]
DOCX from example
Comment 6 Roman Kuznetsov 2020-12-24 17:19:34 UTC
(In reply to Roman Kuznetsov from comment #5)
> Created attachment 168471 [details]
> DOCX from example

MS Word 2007 opens it too fast
Comment 7 Telesto 2020-12-24 18:43:09 UTC
@Noel
As perf magician (who is working on XML code) .. you might be interested..
Comment 8 NISZ LibreOffice Team 2020-12-30 14:11:13 UTC
This file has about 850 footnotes/endnotes. Likely the same problem as bug #76260.
Comment 9 Xisco Faulí 2021-02-19 16:24:11 UTC
Issue fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=7dd8f8aace536a8e60e87e61ee1d90d61fba15eb

Before the commit it takes

real	4m52,958s
user	4m51,267s
sys	0m1,559s

and after

real	0m13,604s
user	0m12,569s
sys	0m0,964s

closing as dupe of bug 120351

*** This bug has been marked as a duplicate of bug 120351 ***