Bug 139266 - Page border from continuous section not imported into DOCX
Summary: Page border from continuous section not imported into DOCX
Status: RESOLVED DUPLICATE of bug 89297
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DOCX-Section
  Show dependency treegraph
 
Reported: 2020-12-27 20:06 UTC by Telesto
Modified: 2021-01-02 13:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (9.50 KB, application/vnd.oasis.opendocument.text)
2020-12-27 20:06 UTC, Telesto
Details
The example files docx version in LO 5.2 and 5.3 (73.85 KB, image/png)
2020-12-30 15:41 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-12-27 20:06:11 UTC
Description:
Page border not exported into DOCX

Steps to Reproduce:
1. Open the attached file
2. Save as DOCX
3. File reload

Actual Results:
No page border

Expected Results:
Page border


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 315c7570c4a72f4c834086082825533b1e50d1bf
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

and in
6.2

and in
Versie: 5.3.5.2 
Build ID: 50d9bf2b0a79cdb85a3814b592608037a682059d
CPU-threads: 4; Besturingssysteem:Windows 6.2; UI-render: standaard; Layout Engine: new; 
Locale: nl-NL (nl_NL); Calc: CL

working in
4.4.7.2
Comment 1 Telesto 2020-12-27 20:06:25 UTC
Created attachment 168524 [details]
Example file
Comment 2 raal 2020-12-28 09:19:38 UTC
Confirm Version: 7.2.0.0.alpha0+
Build ID: 2577d9ecea199ca2c10d852cf279053a1b22faf7
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded
Comment 3 NISZ LibreOffice Team 2020-12-30 15:41:10 UTC
Created attachment 168581 [details]
The example files docx version in LO 5.2 and 5.3

The second pages border was visible in 5.2, but not anymore in 5.3.

However, Word still did display it, so this is more like an import problem.

In 7.0 however another change happened and since then Word displays no second page.
Comment 4 NISZ LibreOffice Team 2020-12-30 20:13:52 UTC
Border from the second page started to disappear at:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=a60b2f7c227709d27d6294558fd396557a9ffd20

author	Justin Luth <justin_luth@sil.org>	2016-07-04 21:39:37 +0300
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2016-07-08 07:24:10 +0000

tdf#64372 docx import: don't ignore continuous section break

Adding CC to: Justin Luth

But there is a lot of problems with this one. There is a section followed by a text:soft-page-break - how does even one create that in Writer?
Comment 5 Telesto 2020-12-30 20:46:09 UTC
(In reply to NISZ LibreOffice Team from comment #4)
> But there is a lot of problems with this one. There is a section followed by
> a text:soft-page-break - how does even one create that in Writer?

For a difference a self-made doc. Made by the following:
Insert -> Section -> Column Tab -> Click Two Column template
Comment 6 NISZ LibreOffice Team 2020-12-31 09:17:01 UTC
(In reply to NISZ LibreOffice Team from comment #3)
> In 7.0 however another change happened and since then Word displays no
> second page.

This seems to be started with:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=f25985c55541cbbc9a4fc79e660592d3d0485196

author	Justin Luth <justin.luth@collabora.com>	2020-03-13 07:14:29 +0300
committer	Miklos Vajna <vmiklos@collabora.com>	2020-03-18 09:29:03 +0100

tdf#131304 .docx: flag new files as MS Word 2019 native mode

I guess it would be better to split this part out as a separate bug.
Comment 7 Telesto 2020-12-31 09:23:04 UTC
(In reply to NISZ LibreOffice Team from comment #6)
> (In reply to NISZ LibreOffice Team from comment #3)
> > In 7.0 however another change happened and since then Word displays no
> > second page.
> 
> This seems to be started with:
> 
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=f25985c55541cbbc9a4fc79e660592d3d0485196
> 
> author	Justin Luth <justin.luth@collabora.com>	2020-03-13 07:14:29 +0300
> committer	Miklos Vajna <vmiklos@collabora.com>	2020-03-18 09:29:03 +0100
> 
> tdf#131304 .docx: flag new files as MS Word 2019 native mode
> 
> I guess it would be better to split this part out as a separate bug.

Yup. I assume NISZ will create that one. And thanks for the bibisect!
Comment 8 Justin L 2021-01-02 13:26:07 UTC
This is all continuous section breaks, and therefore in LO the result is basically undefined since there is nothing to indicate when these settings should start or stop.

*** This bug has been marked as a duplicate of bug 89297 ***