Bug 139335 - UI: LibreOffice product flavor Community branding
Summary: UI: LibreOffice product flavor Community branding
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:7.2.0 target:7.1.0.2
Keywords:
: 139334 139347 139882 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-12-31 09:41 UTC by Telesto
Modified: 2021-01-24 17:56 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-12-31 09:41:05 UTC
Description:
UI: LibreOffice Community in Title bar

Steps to Reproduce:
1. Launch LibreOffice (Start center)


Actual Results:
Title bar showing LibreOffice

Expected Results:
LibreOffice Community. 


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 4e3ce9dd6ace0b22f7b3f45cf2338b201f4dc305
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 V Stuart Foote 2020-12-31 16:17:30 UTC
It is already added, but just as the branding artwork slug on the Help -> About dialog

That is sufficient--the new "branding" tags do not *need* to be in the 'ooName' decorating the frame. Especially if there is any substantial CSD change for bug 113388

IMHO => NAB

=-ref-=
https://gerrit.libreoffice.org/c/core/+/107820
https://gerrit.libreoffice.org/c/core/+/107918
Comment 2 V Stuart Foote 2020-12-31 16:33:46 UTC
The original commits for the --with-product-flavor "Personal" mess were here

https://gerrit.libreoffice.org/c/core/+/97427

would expect that to be revisited, with default 'Personal' now tweaked to the BoD approved 'Community' slug.
Comment 3 Telesto 2020-12-31 17:20:52 UTC
(In reply to V Stuart Foote from comment #1)
> It is already added, but just as the branding artwork slug on the Help ->
> About dialog
> 
> That is sufficient--the new "branding" tags do not *need* to be in the
> 'ooName' decorating the frame. Especially if there is any substantial CSD
> change for bug 113388
> 
> IMHO => NAB
> 
> =-ref-=
> https://gerrit.libreoffice.org/c/core/+/107820
> https://gerrit.libreoffice.org/c/core/+/107918


Adding Italo & Thorsten. Seeing this also as matter of marketing and topic for BoD

It's brought up in the mailing list a few times.. not sure if a final decision being reached on it. 

Don't think the current approach - with very subtitle pointer to community - delivering the idea of Marketing had in mind. 

I really prefer an explicit decision up the chain. And getting it done for 7.1. Instead of subtle try out with an extended debate to 7.2 release for where 'Community' should be placed (or not).

The BoD decision left out the details. The worker bees decided to do the minimum. But well would want to have the burned of aggressive branding with 'authorization'

So my 2 cents about the outcome.. however I do like a final decision from organ (BoD) who is in charge, responsible (and accountable). 

It's ultimately their decision; and having to cope/handle the fall-out/ angry mob (the less appreciated part of BoD job description). The dictate the course we are heading.

It's not up to me, Italo, ux-members. We might have preferences ourselves. But this is about 'greater good' (whatever that means). 

And the worker bees need to ultimately executing what's decided up the chain (or will be done one way or another). 
We can prefer or dislike it, etc.. but matter of lobbying at members or attempt a coupe on the current BoD [a coupe is not advised, IMHO] 

Italo has 'lost' already something. He has cope with 'Community'. Not it his favorite for marketing reasons. Time will tell if he was right.. Nobody will be fully content with the outcome, I estimate. 

--  
For the record: this is a 'general comment' implying anything. But I find it curious that the old revert approach 'Personal Edition" was prominent all over the place, in the worst possible form, while currently approach being oddly subtle/mild. 

---
And maybe this should be discussed somewhere else.. but well, I presented it as a task :P
Comment 4 V Stuart Foote 2020-12-31 18:19:10 UTC
*** Bug 139334 has been marked as a duplicate of this bug. ***
Comment 5 V Stuart Foote 2020-12-31 19:16:11 UTC
*** Bug 139347 has been marked as a duplicate of this bug. ***
Comment 6 Heiko Tietze 2021-01-11 15:39:43 UTC
First patch submitted and in discussion.
Comment 7 Commit Notification 2021-01-14 08:25:52 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2d69acfde50cb0e06a9a057939078fd102d371a3

Resolves tdf#139343 and tdf#139335 - Community/Enterprise flavor

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Heiko Tietze 2021-01-14 12:39:31 UTC
It was decided to add "Community" after the version info for 7.1 and reconsider a more elaborate text for 7.2. We are just behind the string freeze.
Comment 9 Commit Notification 2021-01-14 19:28:47 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/bd319954e82da64d1ca037df2f32982af6ddb0e2

Resolves tdf#139343 and tdf#139335 - Community/Enterprise flavor

It will be available in 7.1.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Jean-Baptiste Faure 2021-01-16 16:31:42 UTC
(In reply to Commit Notification from comment #9)
> Heiko Tietze committed a patch related to this issue.
> It has been pushed to "libreoffice-7-1":
>  [...]
> Affected users are encouraged to test the fix and report feedback.

With this patch in in LO 7.1.1.0.0+ the startcenter is missing the 4 first icons (Open File, Remote Files, Recent Documents and Templates). It's ok in master.

Best regards. JBF
Comment 11 Heiko Tietze 2021-01-18 12:35:43 UTC
(In reply to Jean-Baptiste Faure from comment #10)
> With this patch in in LO 7.1.1.0.0+ the startcenter is missing...

Same reported in bug 139343. Please add a new ticket for the issue.
Comment 12 V Stuart Foote 2021-01-24 17:56:15 UTC
*** Bug 139882 has been marked as a duplicate of this bug. ***