Bug 139338 - The distinction paragraph <-> Character direct formatting in style inspector seems a kind of pointless
Summary: The distinction paragraph <-> Character direct formatting in style inspector ...
Status: CLOSED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.1.0.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Styles_Inspector
  Show dependency treegraph
 
Reported: 2020-12-31 14:07 UTC by Telesto
Modified: 2021-01-13 15:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screencast (1.45 MB, video/mp4)
2021-01-12 12:48 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-12-31 14:07:49 UTC
Description:
The distinction paragraph <-> Character direct formatting in style inspector seems a kind of pointless

Steps to Reproduce:
1. Open Writer
2. Enable style inspector in sidebar
3. Set font to Arial 
4. Type Hello
5. Press Space 
6. Change font to Aharoni
7. Type World
8. Press Space
9. Select Hello + space
10. Change font to Aharoni
11. Go type on in after world



Actual Results:
Paragraph DF style shows Arial, while Arial not being present anyware

Expected Results:
Is it relevant to split 'Paragraph DF from Character DF inside the style inspector (for that matter by default).

I surely don't no how to 'revert' character DF without touching Paragraph DF. Selecting the area and apply a different PS does remove both?


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 4e3ce9dd6ace0b22f7b3f45cf2338b201f4dc305
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Heiko Tietze 2021-01-12 10:40:57 UTC
Absolutely not. Character properties are not set via direct paragraph settings. Actually I don't see any overlapping. But if you merge the sources how should a user learn where the attribute comes from?
Comment 2 Telesto 2021-01-12 12:48:58 UTC
Created attachment 168838 [details]
Screencast

Still not totally clear what the meaning is of Paragraph Direct Formatting
Comment 3 Telesto 2021-01-12 12:52:24 UTC
(In reply to Heiko Tietze from comment #1)
> Absolutely not. Character properties are not set via direct paragraph
> settings. Actually I don't see any overlapping. But if you merge the sources
> how should a user learn where the attribute comes from?

Please see screencast.. And explain to me what I should make off it.. 
Not sure how I get back to 'paragraph direct formatting' following comment 0

Setting to UNCONFORMED in for answer for now.. Could also set it NEEDINFO, but would be the opposite of what NEEDINFO means in normal cases.
Comment 4 Mike Kaganski 2021-01-12 13:13:14 UTC
(In reply to Telesto from comment #0)
> The distinction paragraph <-> Character direct formatting in style inspector
> seems a kind of pointless

(In reply to Telesto from comment #3)
> And explain to me what I should make off it.. 

I'm sorry, is this a kind of "I don't understand what it is, so let's break it" kind of request? So someone who does not understand the difference, and actually has no actual problem with it, tries to "simplify" things they don't understand?
Comment 5 Telesto 2021-01-12 16:30:18 UTC
(In reply to Mike Kaganski from comment #4)
> (In reply to Telesto from comment #0)
> > The distinction paragraph <-> Character direct formatting in style inspector
> > seems a kind of pointless
> 
> (In reply to Telesto from comment #3)
> > And explain to me what I should make off it.. 
> 
> I'm sorry, is this a kind of "I don't understand what it is, so let's break
> it" kind of request? So someone who does not understand the difference, and
> actually has no actual problem with it, tries to "simplify" things they
> don't understand?

More intended as an inquiry.. of naïve asking what the idea behind the concept is.. Not to get comment 0 through.

That I report it as a 'bug' doesn't necessary mean it's bug. Except I tend to perceive it as bug 'initially; .

I don't not really get that it's possible to 'set a DF at paragraph level', which is overridden by Character DF formatting.. for the full paragraph depend how the formatting being changed..

So changing the font at the start is assumed to be DF paragraph style, but maybe it intended only to have say a Different type of font for the first letter? Or fist word.. 

And PS direct formatting obviously causes a lot of DF being present.. While styles a propagated. So maybe you only want to change DF at character level, and you get 'DF at paragraph level'

And having to types of direct formatting is really hard get a grip on. As kind of invisible.. Yes, with style inspector it's visible.. but now I have having trouble avoiding certain effects.

As hard as switching font from to something else, back to default doesn't mean.. back in line with 'style', but DF formatting font set. Which also hard to revert. [I my position is that shouldn't happen ideally in the first place]

But maybe I change position what the idea behind Paragraph DF is. As it's not clear to me what purpose/advantage is next to DF at character level.. This might be 'sane' approach or having an advantage.. I can place it currently. Why this is needed/wanted. In relation to Character DF and in relation to using PS Styles.
Comment 6 Aron Budea 2021-01-12 16:38:16 UTC
(In reply to Telesto from comment #5)
> And having to types of direct formatting is really hard get a grip on. As
> kind of invisible.. Yes, with style inspector it's visible.. but now I have
> having trouble avoiding certain effects.
This situation reminds me of changing a piece of text eg. to bold, then changing back to regular. You won't see a difference, but it'll still have direct formatting, regular, you have to clear the formatting for the text to become unformatted.

Also, this whole discussion is completely unrelated to the Styles Inspector, which just shows what exists in the document.
Comment 7 Telesto 2021-01-12 16:48:11 UTC
(In reply to Aron Budea from comment #6)
> (In reply to Telesto from comment #5)
> > And having to types of direct formatting is really hard get a grip on. As
> > kind of invisible.. Yes, with style inspector it's visible.. but now I have
> > having trouble avoiding certain effects.
> This situation reminds me of changing a piece of text eg. to bold, then
> changing back to regular. You won't see a difference, but it'll still have
> direct formatting, regular, you have to clear the formatting for the text to
> become unformatted.
> Also, this whole discussion is completely unrelated to the Styles Inspector,
> which just shows what exists in the document.

You're right Aron.. I was kind of focused on Style Inspector, because being surprised by seeing Direct Formatting at Paragraph level.. Whereas I assumed this to be only happening at Character Level.

And in a follow up found it pretty confusing having multiple DF settings set. Which not even 'match' reality. So you can have a paragraph with DF saying font X. Where its overwritten by DF Character Style for the full paragraph.

But is indeed not the 'fault' of the style inspector. It's only making some of internal clear.. I didn't even realized existed.. 

But core is indeed not about the style inspector
Comment 8 Telesto 2021-01-12 16:51:36 UTC
(In reply to Aron Budea from comment #6)
> This situation reminds me of changing a piece of text eg. to bold, then
> changing back to regular. You won't see a difference, but it'll still have
> direct formatting, regular, you have to clear the formatting for the text to
> become unformatted.

Bug 135871 being one of those (and Bug 135871 comment 22 listing even more)
Comment 9 Mike Kaganski 2021-01-12 17:39:51 UTC Comment hidden (off-topic)
Comment 10 Telesto 2021-01-12 19:52:08 UTC Comment hidden (off-topic)
Comment 11 Mike Kaganski 2021-01-12 22:24:37 UTC Comment hidden (off-topic)
Comment 12 V Stuart Foote 2021-01-12 22:44:44 UTC Comment hidden (off-topic)
Comment 13 Mike Kaganski 2021-01-13 06:54:30 UTC Comment hidden (off-topic)
Comment 14 Telesto 2021-01-13 09:05:20 UTC Comment hidden (off-topic)
Comment 15 Mike Kaganski 2021-01-13 10:30:30 UTC Comment hidden (off-topic)