Bug 139799 - Convert all charts to png or other image format on export to *.doc or *.docx format
Summary: Convert all charts to png or other image format on export to *.doc or *.docx ...
Status: RESOLVED DUPLICATE of bug 61658
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-21 06:11 UTC by andis.lazdins
Modified: 2021-01-21 09:47 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andis.lazdins 2021-01-21 06:11:54 UTC
Description:
Possibility to export charts to Microsoft format, when *.odt document is saved as *.doc or *.docx is now implemented in Libreoffice; however, quite often charts loose formatting elements or even contents or they are interpreted in wrong way during export to *.doc or *.docx formats. It's then very laborious to replace charts one by one with pictures; therefore the possibility to convet charts to images directly on saving to *.doc or *.docx would be very feasible addition saving a lot of time. This could be implemented as additional option under Load/Save, so that user can select to try to export charts to *.doc or *.docx formats or to save them as images.

Steps to Reproduce:
1.Create chart, e.g. complex x/y scatter with several trendlines and some thousands of records in *.odt file and save as *.doc or *.docx
2. Open created file in Microsoft Word.

Actual Results:
Charts are exported to *.doc or *.docx, but complex charts in the most cases will be defaced or even damaged and should be manually restored one by one, either by replacing of images (copy chart in Libreoffice and past in Word, resolution is very poor) or by manual editing, if the contents is not damaged. Both options are time consuming and should be repeated on every export  to *.doc or *.docx format.

Expected Results:
User can choose in options to try to convert charts to *.doc or *.docx chart or to high resolution image, e.g. *.png.In case of choosing conversion to images, all charts in the document after saving to *.doc or *.docx are converted to selected image format without loosing visual quality, anchoring and other options.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.4.2
Build ID: dcf040e67528d9187c66b2379df5ea4407429775
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: lv-LV (en_US.UTF-8); UI: en-US
Calc: CL
Comment 1 Timur 2021-01-21 09:47:59 UTC
Makes no sense. Anyway it's a duplicate of the same reporter.

*** This bug has been marked as a duplicate of bug 61658 ***