Bug 139800 - Feature Request: Favorite Files pane needed in Side bar
Summary: Feature Request: Favorite Files pane needed in Side bar
Status: RESOLVED DUPLICATE of bug 77590
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.1.0.2 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Sidebar
  Show dependency treegraph
 
Reported: 2021-01-21 06:31 UTC by Quintao
Modified: 2021-08-11 16:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Quintao 2021-01-21 06:31:46 UTC
Description:
After opening Writer, the next action I take 99% of the time is click on the small arrow next to the Open files button to access the Recent files list.

This of course is a vital feature of itself, which must save everyone so much time in getting back to files that need work.

But it has its limitations, those being:
1. the number of files that it can display - this means if we work on say, 50 files, we can't quickly access them all with this list
2. inability to remove entries that are not needed or irrelevant (file has moved etc)
3. important files can get pushed off the list - e.g. files from last week disappear from list due to files this week but work will continue on those other files soon
4. files can be in any order or place on the list

What frustrates me most is that my top priority files disappear from the list and I must then find them all over again in the Open file dialogue, which means navigating folder hierarchies.

What I need is a Favorites Pane, over on the Side panel, where I can keep a list of important files that I can access easily.

Ideas for this Favorites pane:
1. A toolbar at top with some buttons: the standard Open file button, Add current to list, Add new to list, remove selected from list, Re-target moved file
2. Double click to open a file, or Right-click menu with Open, Remove
3. Sorting options like A-Z or Z-A, date modified, size, owner etc
4. Set colour tags to files with an Apply tag button, and a Filter by tag button, to group different files together
5. Folders that can be named, expandable, can drag a favourite into any


Steps to Reproduce:
1.Open a file, "A.odt"
2.Open 30 other files
3.Click on Recent files list


Actual Results:
The original file "A.odt" is not on the Recent files list, it has been pushed off!

Expected Results:
I would like to be able to access the file "A.odt" at any time, from a fixed list, without needing to remember in which folder it is kept and have to find it over and over.


Reproducible: Always


User Profile Reset: No



Additional Info:
[Can't select the text in Help > About]
Comment 1 Quintao 2021-02-08 07:02:31 UTC
One work around is to have a folder with symlinks to documents so that hey can be opened from a file browser any time without searching so much.

I have tried and I get stuck (or bored) because of the fact that with every new release of LibreOffice it ships with the release version appended to the name, which means I have to edit multiple menu entries (Linux Openbox desktop) or create an executable script in /usr/bin which points to Libreoffice[n], which needs editing also with each new update.

/usr/bin/libreoffice

#!/bin/bash
libreoffice7.1 --writer $@
Comment 2 Roman Kuznetsov 2021-08-04 17:11:55 UTC
I don't think we want to have a file explorer inside LibreOffice

-1 from me
Comment 3 Heiko Tietze 2021-08-11 10:30:41 UTC
In bug 143495 a similar request takes the start center as basis. Can we make your request a duplicate?

A few thoughts: opening multiple files and having favorites sounds like a desirable feature. The toolbar button with recent files wouldn't be a good place, another sidebar deck might be. But we do have the start center for this purpose and reload the previously opened files automatically sounds even better.
Comment 4 V Stuart Foote 2021-08-11 16:19:02 UTC
Rather than bug 143495 (for reopen/restore of multiple documents) this is more a dupe of bug 77590 which could be exposed in an additional SB deck--or some other view toggle to expose the MRU thumbnail views--marked it such.

*** This bug has been marked as a duplicate of bug 77590 ***