Bug 139857 - Cannot copy text at Formula Bar with mouse
Summary: Cannot copy text at Formula Bar with mouse
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.0.2 rc
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.2.0 target:7.1.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Calc-Formula-Bar
  Show dependency treegraph
 
Reported: 2021-01-23 09:54 UTC by baffclan
Modified: 2021-01-27 15:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description baffclan 2021-01-23 09:54:19 UTC
Description:
Cannot copy text at Formula Bar with mouse


Steps to Reproduce:

1. Create a New Calc document
2. Click on any cell (e.g. A1)
3. Enter "AAA" in the cell
4. Click a Formula Bar, and right click -> Select All
5. Right click again, -> Copy


Actual Results:
"AAA" cannot be copied


Expected Results:
"AAA" can be copied


Reproducible: Always


User Profile Reset: No



Additional Info:
Reproduce LibO:

Version: 7.1.0.2 (x64) / LibreOffice Community
Build ID: 53d68d29d90fd16448721a60aad68c28ff0809f5
CPU threads: 12; OS: Windows 10.0 Build 19041; UI render: default; VCL: win
Locale: ja-JP (ja_JP); UI: en-US
Calc: CL

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 2081eac430ac69619149e44b453a2d7dda41fc83
CPU threads: 12; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: ja-JP (ja_JP); UI: ja-JP
Calc: CL
Comment 1 Uwe Auer 2021-01-23 16:12:55 UTC
repro

Version: 7.1.0.2 (x64) / LibreOffice Community
Build ID: 53d68d29d90fd16448721a60aad68c28ff0809f5
CPU threads: 1; OS: Windows 10.0 Build 19042; UI render: default; VCL: win
Locale: de-DE (en_DE); UI: en-US
Calc: threaded
Comment 2 Roman Kuznetsov 2021-01-23 20:34:28 UTC
selected text drops its selecting when you right click on it

works fine in 7.0 but not in 7.1.0.1 => regression

I bisected it

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.1 ((oldest))
$ git bisect start master oldest
Bisecting: 2982 revisions left to test after this (roughly 12 steps)
[75e5b10d8e97d2e7ee0829e769c627c87845d46f] source sha:f700902e903ee610cb5ff58769ee4ca345b4f696

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.1 ((75e5b10d8...)|BISECTING)
$ instdir/program/soffice --calc

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.1 ((75e5b10d8...)|BISECTING)
$ git bisect good
Bisecting: 1491 revisions left to test after this (roughly 11 steps)
[e9223fa17b6fc30c6ae0c43c0ee365e4b3d093e2] source sha:9310e47e2ce71348a16e5412131946348833f4b2

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.1 ((e9223fa17...)|BISECTING)
$ instdir/program/soffice --calc

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.1 ((e9223fa17...)|BISECTING)
$ git bisect good
Bisecting: 745 revisions left to test after this (roughly 10 steps)
[f6bb17c235fd54f21cb0ebc1e00e739ebedb8a8f] source sha:81fe31d2c8977791f9b90ab1da4fbb1a778f87fb

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.1 ((f6bb17c23...)|BISECTING)
$ instdir/program/soffice --calc

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.1 ((f6bb17c23...)|BISECTING)
$ git bisect bad
Bisecting: 372 revisions left to test after this (roughly 9 steps)
[52afd45627a1035198f12adfac0d5d9f58d51985] source sha:17d48cd63a19adf41d1355f74468a621e5c6f108

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.1 ((52afd4562...)|BISECTING)
$ instdir/program/soffice --calc

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.1 ((52afd4562...)|BISECTING)
$ git bisect bad
Bisecting: 186 revisions left to test after this (roughly 8 steps)
[1ae995c4da69c376b104dcf376b4c7b4f6ef1f55] source sha:b225980d2d65694278c9ed89512fbe21b08febd6

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.1 ((1ae995c4d...)|BISECTING)
$ instdir/program/soffice --calc

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.1 ((1ae995c4d...)|BISECTING)
$ git bisect bad
Bisecting: 92 revisions left to test after this (roughly 7 steps)
[b7b5f3ef3669b78b79e863e045b735912e740228] source sha:30668130ce82c3f45af38ab419ec04fdb67c4509

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.1 ((b7b5f3ef3...)|BISECTING)
$ instdir/program/soffice --calc

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.1 ((b7b5f3ef3...)|BISECTING)
$ git bisect bad
Bisecting: 46 revisions left to test after this (roughly 6 steps)
[3e5b3d0053937223b246a07c1606e857fbbf8f95] source sha:8ed2f358cc2a668600e602cb0515ff6af16c2824

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.1 ((3e5b3d005...)|BISECTING)
$ instdir/program/soffice --calc

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.1 ((3e5b3d005...)|BISECTING)
$ git bisect good
Bisecting: 23 revisions left to test after this (roughly 5 steps)
[322588ca6de768abf4f92fce0085b118abfe186d] source sha:3e062a80a8f329b593f85a4b3a065389a9e16577

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.1 ((322588ca6...)|BISECTING)
$ instdir/program/soffice --calc

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.1 ((322588ca6...)|BISECTING)
$ git bisect good
Bisecting: 11 revisions left to test after this (roughly 4 steps)
[71d2dbd1182c1881727c042283596160f933aad0] source sha:a559ddd37b09a35f26a291f1a0f94608309a7d99

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.1 ((71d2dbd11...)|BISECTING)
$ instdir/program/soffice --calc

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.1 ((71d2dbd11...)|BISECTING)
$ git bisect good
Bisecting: 5 revisions left to test after this (roughly 3 steps)
[be13f1de5921508c560b9b1cbf9481bc04c1ae9c] source sha:c7ada1cc8a294f0d2da32ffc02d0941b1b1afd29

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.1 ((be13f1de5...)|BISECTING)
$ instdir/program/soffice --calc

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.1 ((be13f1de5...)|BISECTING)
$ git bisect good
Bisecting: 2 revisions left to test after this (roughly 2 steps)
[23127f0640852e8db00361827a2c1257381d11d6] source sha:e087e25f05e689091cbf1c4f91b6e93878ac17ec

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.1 ((23127f064...)|BISECTING)
$ instdir/program/soffice --calc

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.1 ((23127f064...)|BISECTING)
$ git bisect bad
Bisecting: 0 revisions left to test after this (roughly 1 step)
[70315057f8d86b3faed128933da35528ca3132df] source sha:d6b7cc3f7c07b98c90194e8b33cf44b94804b525

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.1 ((70315057f...)|BISECTING)
$ instdir/program/soffice --calc

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.1 ((70315057f...)|BISECTING)
$ git bisect good
23127f0640852e8db00361827a2c1257381d11d6 is the first bad commit
commit 23127f0640852e8db00361827a2c1257381d11d6
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Fri Oct 16 04:09:52 2020 -0700

    source sha:e087e25f05e689091cbf1c4f91b6e93878ac17ec

https://git.libreoffice.org/core/commit/e087e25f05e689091cbf1c4f91b6e93878ac17ec

Added CC: to Caolan McNamara
Comment 3 Caolán McNamara 2021-01-25 09:31:18 UTC
losing focus to the menu must be a problem for some reason
Comment 4 Commit Notification 2021-01-25 21:01:56 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a91d640211745dc8807244cc4af787e98046ce93

tdf#139857 release mouse on launch context menu

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Caolán McNamara 2021-01-25 21:02:37 UTC
fixed in master, backports to 7-1 and 7-1-0 in gerrit
Comment 6 Commit Notification 2021-01-25 21:12:55 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/2988bd19eff4053d557ef9d1e70aa7b75665cbcb

tdf#139857 release mouse on launch context menu

It will be available in 7.1.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 baffclan 2021-01-26 12:30:32 UTC
Cannot reproduce with Today's Build. 
Thanks for fixing this!

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 01ac21d99fb9945f9d3ab2fe3ed04e3c86fa5583
CPU threads: 12; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: ja-JP (ja_JP); UI: ja-JP
Calc: CL
Comment 8 Commit Notification 2021-01-27 14:40:25 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-1-0":

https://git.libreoffice.org/core/commit/44d2f2e2cb3ad893bdf1e9b11689297e2f7e29b4

tdf#139857 release mouse on launch context menu

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.