Bug 139892 - lowriter does not handle emoji's properly
Summary: lowriter does not handle emoji's properly
Status: RESOLVED DUPLICATE of bug 129523
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.6.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-25 01:58 UTC by Noloader
Modified: 2021-02-09 07:40 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Zip file with a ODT file with emoji, and the converted PDF file (19.49 KB, application/zip)
2021-01-25 01:58 UTC, Noloader
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Noloader 2021-01-25 01:58:25 UTC
Created attachment 169128 [details]
Zip file with a ODT file with emoji, and the converted PDF file

Hi Everyone,

I'm working on Ubuntu 20.04 (Focal), x86_64, fully patched. Ubuntu 20 has LibreOffice 6.4.6.2 40 (Build:2).

I am using lowriter to convert an ODT to a PDF from the command line. The ODT has emoji's in them, like:

    โ€œBonnie Conte shared "๐Ÿ’‹FUCK๐Ÿ’‹ ME๐Ÿ’‹ TONIGHT!!! ๐Ÿ’‹๐Ÿ’‹" with you.โ€

After processing with lowriter, the PDF lacks the emoji's:

    โ€œBonnie Conte shared "   FUCK   ME   TONIGHT!!!    " with you.โ€

The script I am using is pretty simple. Here is the relevant part:

    for odt_file in "${odt_files[@]}"
    do
        lowriter --convert-to pdf "${odt_file}"
    done

It is important the the emoji's survive since I am preparing a legal complaint. I want to court to see an accurate representation of the email message.

==========

It is not clear to me if the bug report Component should be "Printing and PDF export" or "Writer". My apologies if "Writer" is worng.

==========

$ apt-cache show libreoffice
Package: libreoffice
Architecture: amd64
Version: 1:6.4.6-0ubuntu0.20.04.1
Priority: optional
Section: universe/editors
Origin: Ubuntu
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Comment 1 Dieter 2021-02-09 07:21:00 UTC
Sounds like a duplicate of bug 129523 to me.

*** This bug has been marked as a duplicate of bug 129523 ***
Comment 2 Noloader 2021-02-09 07:40:47 UTC
(In reply to Dieter from comment #1)
> Sounds like a duplicate of bug 129523 to me.
> 
> *** This bug has been marked as a duplicate of bug 129523 ***

Thanks Dieter.

Sorry about the duplicate. I'm not sure why the search for the Emoji issue turned up no hits.

(I am not too impressed with Bugzilla's search feature. It seems to be stuck in the 1990s).

Jeff