Bug 140006 - Drop down text is not full lenght of the column (see comment 4 for a test file)
Summary: Drop down text is not full lenght of the column (see comment 4 for a test file)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.2.0 target:7.1.2 target:7.0.5
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2021-01-29 19:09 UTC by James Warmuth
Modified: 2021-02-11 16:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
the test file (9.19 KB, application/vnd.oasis.opendocument.spreadsheet)
2021-01-29 21:12 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James Warmuth 2021-01-29 19:09:01 UTC
Description:
I submitted this as a bug however I was told it is not one even though it is fine in version 6 but not 7.  

I use Calc with large validation fields and set them up as drop downs so the user can select an option from a list.  In Version 6 the drop down fields would display much larger making it easier for the user to pick the correct option however in version 7 these fields display much shorter and cut the text off so it is harder for the user to see what they are choosing.  v7 https://ibb.co/7kWhJnH and this image for version 6 https://ibb.co/WtqL3S6.  You may also reference Bug 138579.    

Steps to Reproduce:
1.Create a large validation cell with drop downs
2.Attempt to view the dropdown
3.

Actual Results:
The filed is clipped in version 7 but in version 6 it displays the length of the field.  

Expected Results:
Version 6 behavior,  however long the cell is that is how long the drop down should be.  


Reproducible: Always


User Profile Reset: No



Additional Info:
I still believe this is a bug as the behavior suddenly changed from version 6 to version 7.  The images clearly show the difference.  I don't even understand why anyone would want it the way it is configured in 7 as the rest of the length is just wasted space.
Comment 1 BogdanB 2021-01-29 20:11:52 UTC
Please create an example of a dropdown that is seen different in 6 compaering to version 7.

We need something to test on. It's much easier.

I have created a new dropdown with 2 words, a short one and a long one. The dropdown will be minimum a default size, but of course you cold increse it.

A bug would be if the same file when open with 6 it's a certain size, and opening with another version has another size.

Waiting for your example file.
Comment 2 James Warmuth 2021-01-29 21:00:38 UTC
I have added photos of both in the description.  version 6 is https://ibb.co/WtqL3S6.  version 7 is https://ibb.co/7kWhJnH.  I have also uploaded a ODS file to google drive which is linked here.  https://drive.google.com/file/d/1CzyhoX9vnJtU1cgognUq78VyQAwnPIOh/view?usp=sharing.  Please drip down the one item field in both version and you will see the difference.
Comment 3 James Warmuth 2021-01-29 21:12:03 UTC
I have just created an unlisted youtube video as well trying to explain the issue
https://youtu.be/dMMQEpbmHzk
Comment 4 BogdanB 2021-01-29 21:12:08 UTC
Created attachment 169288 [details]
the test file
Comment 5 BogdanB 2021-01-29 21:15:27 UTC

This is the first version that is bad
Version: 7.0.0.3
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded

---- the bug started here-----

And this is the last version that I tested and is good
Version: 6.4.6.2
Build ID: 0ce51a4fd21bff07a5c061082cc82c5ed232f115
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded
Comment 6 BogdanB 2021-01-29 21:23:27 UTC
3087e0fa7ddfd51f1aa79ed79146f81aa75e204d is the first bad commit
commit 3087e0fa7ddfd51f1aa79ed79146f81aa75e204d
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Mon May 25 20:27:11 2020 +0200

    source sha:df50b02cd3177570bb26484a03273ba5caa50037
    
    source sha:df50b02cd3177570bb26484a03273ba5caa50037

 instdir/program/libsclo.so                         | Bin 22179200 -> 22177824 bytes
 instdir/program/setuprc                            |   2 +-
 instdir/program/versionrc                          |   2 +-
 instdir/share/config/images_breeze.zip             | Bin 1882465 -> 1882465 bytes
 instdir/share/config/images_breeze_dark.zip        | Bin 1878076 -> 1878076 bytes
 instdir/share/config/images_breeze_dark_svg.zip    | Bin 1514726 -> 1514726 bytes
 instdir/share/config/images_breeze_svg.zip         | Bin 1512313 -> 1512313 bytes
 instdir/share/config/images_colibre.zip            | Bin 2504482 -> 2504482 bytes
 instdir/share/config/images_colibre_svg.zip        | Bin 2253863 -> 2253863 bytes
 instdir/share/config/images_elementary.zip         | Bin 4019227 -> 4019227 bytes
 instdir/share/config/images_elementary_svg.zip     | Bin 4947150 -> 4947150 bytes
 instdir/share/config/images_karasa_jaga.zip        | Bin 4844877 -> 4844877 bytes
 instdir/share/config/images_karasa_jaga_svg.zip    | Bin 18995677 -> 18995677 bytes
 instdir/share/config/images_sifr.zip               | Bin 2035766 -> 2035766 bytes
 instdir/share/config/images_sifr_dark.zip          | Bin 2037553 -> 2037553 bytes
 instdir/share/config/images_sifr_dark_svg.zip      | Bin 1691309 -> 1691309 bytes
 instdir/share/config/images_sifr_svg.zip           | Bin 1687605 -> 1687605 bytes
 instdir/share/config/images_sukapura.zip           | Bin 2956886 -> 2956886 bytes
 instdir/share/config/images_sukapura_svg.zip       | Bin 15286061 -> 15286061 bytes
 .../soffice.cfg/modules/scalc/ui/filterlist.ui     |  61 +++++++++++++++++++++
 20 files changed, 63 insertions(+), 2 deletions(-)
 create mode 100644 instdir/share/config/soffice.cfg/modules/scalc/ui/filterlist.ui
Warning: failed to read path from javaldx
Comment 7 BogdanB 2021-01-29 21:30:21 UTC
Caolan please take a look. 
Thanks.
Comment 8 Caolán McNamara 2021-02-10 17:10:09 UTC
This comes about due to merging two pieces of code that both put up a menu-like widget, this one and another for "scenario" menus. The scenario menu one had a preexisting 300 pixel width limit which has ended up being reused for this menu too. Original comment on it was "auch nicht uebertreiben (Pixel)" from the primordial checkin "do not over do it (Pixel)"
Comment 9 Commit Notification 2021-02-10 21:02:49 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ac4e8e8ad407c9a0da808d9f11fd5108048c5d05

tdf#140006 don't limit dropdown width to 300pixels

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Caolán McNamara 2021-02-11 10:37:13 UTC
done in master, backport to 7-1 in gerrit
Comment 11 Commit Notification 2021-02-11 16:42:43 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/055fddbca0efb85e031fbabdf88211fa28bab27e

tdf#140006 don't limit dropdown width to 300pixels

It will be available in 7.1.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2021-02-11 16:42:56 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/d387de2bbd23887c4340fa5fcd64eb5e5ed3cd58

tdf#140006 don't limit dropdown width to 300pixels

It will be available in 7.0.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.