Bug 140067 - [UI] redo causes slide preview selection to be lost
Summary: [UI] redo causes slide preview selection to be lost
Status: RESOLVED DUPLICATE of bug 145491
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.2 all versions
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2021-02-01 15:47 UTC by Xisco Faulí
Modified: 2022-11-23 16:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2021-02-01 15:47:24 UTC
This issue is similar to bug 100950

Steps to reproduce:
1. Open Impress
2. Insert a new slide
3. Type something in the slide
4. Undo -> text insertion is undone
5. Undo -> slide insertion is undone
6. Redo -> slide insertion is redone
7. Redo -> text insertion is redone

-> No slide is selected in the slide sorter

Reproduced in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: f2389a70da606768a39ee599de6a5b24058734aa
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2021-02-01 15:49:09 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=a0de7474400ae0a84daf688de12c9344d028df93

author	Caolán McNamara <caolanm@redhat.com>	2016-05-17 20:34:31 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2016-05-18 12:54:38 +0100
commit a0de7474400ae0a84daf688de12c9344d028df93 (patch)
tree 2b36ffe1989d08d962fa0ca2fb59c6f36a98da45
parent e226c19e9136dda366c1485a9d53a0c5d433387c (diff)
move the KeepSlideSorterInSyncWithPageChanges to a level lower

Bisected with: bibisect-linux-64-5.2

Adding Cc: to Caolán McNamara
Comment 2 Caolán McNamara 2022-11-23 16:25:11 UTC
This is reproducible and doesn't happen with the fix in gerrit for 145491

*** This bug has been marked as a duplicate of bug 145491 ***