Bug 140087 - Writer: Adding lines with accurate position is unreliable
Summary: Writer: Adding lines with accurate position is unreliable
Status: RESOLVED DUPLICATE of bug 122717
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.6.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-02 10:58 UTC by Alan
Modified: 2022-05-30 09:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file with positioned line in .odt format. (8.25 KB, application/vnd.oasis.opendocument.text)
2021-02-02 11:15 UTC, Alan
Details
The docx corrupted file (4.69 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2021-02-02 11:16 UTC, Alan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alan 2021-02-02 10:58:08 UTC
Description:
I have been trying to create a document which will ultimately be used as a template fed into PHPOffice. As part of the document I tried adding lines using the Insert Line button and positioning them accurately. Their position on the page is important. During the operation all looks good and I can use the dialogue to position the line where I want and select the Protect position and size options.

If I then close Writer, and re-open the file, the lines have moved. In some extreme examples, I had lines change from being vertically oriented down the page borders to horizontal running across the middle of the page!

I am using Version: 6.4.6.2
Build ID: 1:6.4.6-0ubuntu0.20.04.1
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded

I have also installed and tried using version 7.0.4 but it exhibited the same issue.


Steps to Reproduce:
1. Open a new document
2. Use the Insert Line button and add a line
3. Use the Position and size dialogue to accurately position the line, say down the left-hand page text area, choose Protect Position
4. Right-click on the line and choose Arrange->Send to Back
5. Save the document and close LibreOffice.
6. Re-open the document and the line will not be in exactly the same position.
4. Add some more content to the document like tables or frames.

Actual Results:
The lines move

Expected Results:
The lines should not move.


Reproducible: Sometimes


User Profile Reset: No



Additional Info:
Version: 6.4.6.2
Build ID: 1:6.4.6-0ubuntu0.20.04.1
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded
Comment 1 Alan 2021-02-02 11:02:17 UTC
I couldn't see the option to "Use OpenGL for all rendering" but this is the output of the suggested command in the terminal:

test@lobsang:~$ glxinfo | grep OpenGL
OpenGL vendor string: Intel
OpenGL renderer string: Mesa Intel(R) HD Graphics 530 (SKL GT2)
OpenGL core profile version string: 4.6 (Core Profile) Mesa 20.2.6
OpenGL core profile shading language version string: 4.60
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6 (Compatibility Profile) Mesa 20.2.6
OpenGL shading language version string: 4.60
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 20.2.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:
Comment 2 Alan 2021-02-02 11:13:22 UTC
Important bit of information... You must save the document as a MS Word 2007 - 365 docx. When you reopen the file the line has switched orientation. I will attach an example file
Comment 3 Alan 2021-02-02 11:15:30 UTC
Created attachment 169388 [details]
Example file with positioned line in .odt format.

This opens OK. But if you save it as a docx and open the docx then the line is horizontal across the page.
Comment 4 Alan 2021-02-02 11:16:57 UTC
Created attachment 169389 [details]
The docx corrupted file

This is what happens when I save it as a docx.
Comment 5 Alan 2021-02-02 11:23:12 UTC
A little more information which might be helpful.

My use-case as mentioned is to create a sort of "template" which I feed into PHPOffice/PHPWord, replace some content using the template processor[1], and then I am using a headless version of LibreOffice to generate a PDF, or other file format.

When used headless, I believe that the line doesn't move, suggesting to me that the corruption is happening during the rendering to the screen?

[1] https://github.com/PHPOffice/PHPWord/blob/develop/docs/templates-processing.rst
Comment 6 Stéphane Guillou (stragu) 2021-02-02 14:29:20 UTC
Reproduced when saving as docx with:

Version: 7.1.0.3 / LibreOffice Community
Build ID: f6099ecf3d29644b5008cc8f48f42f4a40986e4c
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

and:

Version: 7.0.4.2
Build ID: 00(Build:2)
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Ubuntu package version: 1:7.0.4_rc2-0ubuntu0.18.04.2
Calc: threaded

I noticed that the original object has a rotation of 0°, and when saved as docx and reopened, it has a rotation of 270°.
Comment 7 Stéphane Guillou (stragu) 2021-02-02 14:36:23 UTC
Could this be a duplicate of https://bugs.documentfoundation.org/show_bug.cgi?id=122717 ?
Comment 8 Gabor Kelemen (allotropia) 2022-05-30 09:49:13 UTC
This looks good now, bibisected in win-7.1 to:

https://git.libreoffice.org/core/+/11d344f6271e4171f8006c2cb29372f612cbdc00

author	Xisco Fauli <xiscofauli@libreoffice.org>	Thu Mar 25 17:38:20 2021 +0100
committer	Xisco Fauli <xiscofauli@libreoffice.org>	Fri Mar 26 11:14:58 2021 +0100
tree d85f1699c24abe7537d019eb3df0ec36d4065fcc
parent 9436ab24a7d08540a7c192df86956d53673c9a08 [diff]

tdf#122717: fix handling of zero width/height lines

*** This bug has been marked as a duplicate of bug 122717 ***