Bug 140151 - Button with link does not work anymore
Summary: Button with link does not work anymore
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.0.3 release
Hardware: All All
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: target:7.2.0 target:7.1.1 target:7.0.5
Keywords: bibisected, bisected, regression
: 140166 140167 140169 140199 (view as bug list)
Depends on:
Blocks: Form-Controls
  Show dependency treegraph
 
Reported: 2021-02-04 13:34 UTC by Aron Budea
Modified: 2021-02-09 11:33 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample ODS (7.91 KB, application/vnd.oasis.opendocument.spreadsheet)
2021-02-04 13:34 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2021-02-04 13:34:55 UTC
Created attachment 169467 [details]
Sample ODS

Open the attached spreadsheet, and click the button.

=> It should take you to cell B111, but it does nothing.

Reproduced using LO 7.2.0.0.alpha0+ (f2389a70da606768a39ee599de6a5b24058734aa), 7.1.0.3 / Ubuntu.
No issue in 7.0.0.3.
=> regression

Bibisected to the 7.1 backport of the following commit using repo bibisect-linux-64-7.1. Adding CC: to Julien Nabet.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=07be45d03f80fa681c697ca9f5a13084a81c7a26
author		Julien Nabet <serval2412@yahoo.fr>	2020-12-02 00:05:14 +0100
committer	Julien Nabet <serval2412@yahoo.fr>	2020-12-02 21:01:45 +0100

tdf#46579: fix form fields 'Image Button' in Forms
Comment 1 Julien Nabet 2021-02-04 18:58:47 UTC
Revert of the initial patch waiting for review on gerrit:
- master: https://gerrit.libreoffice.org/c/core/+/110425
- 7.1: https://gerrit.libreoffice.org/c/core/+/110368
since I don't know at all what's the pb and spent enough time trying to understand the initial tdf#46579.
Comment 2 Commit Notification 2021-02-04 20:21:19 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a444a8dd40cf7035c44ee8ef168be2b3e3144c86

tdf#140151: revert fix for tdf#46579 which caused regression

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Julien Nabet 2021-02-04 20:22:11 UTC
sorry I had forgotten 7.0 branch:
https://gerrit.libreoffice.org/c/core/+/110369

Thank you for having spotted this regression! :-)
Comment 4 Commit Notification 2021-02-05 09:34:04 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/9567639d6a649cffc9f1a965a11b5b202b241179

tdf#140151: revert fix for tdf#46579 which caused regression

It will be available in 7.1.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2021-02-05 11:04:31 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/2a27ff2190a40afe806bbf3577b641390047e209

tdf#140151: revert fix for tdf#46579 which caused regression

It will be available in 7.0.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Alex Thurgood 2021-02-05 11:08:43 UTC
*** Bug 140167 has been marked as a duplicate of this bug. ***
Comment 7 Alex Thurgood 2021-02-05 11:09:03 UTC
*** Bug 140169 has been marked as a duplicate of this bug. ***
Comment 8 Alex Thurgood 2021-02-05 11:09:43 UTC
*** Bug 140134 has been marked as a duplicate of this bug. ***
Comment 9 Alex Thurgood 2021-02-05 11:14:56 UTC
*** Bug 140166 has been marked as a duplicate of this bug. ***
Comment 10 Julien Nabet 2021-02-05 12:19:58 UTC
Thank you Alex for having spotted all these dups!

Sorry guys for the mess I brought with my wrong patch!
I'll stay away from this part for sure to avoid more mistakes.
Comment 11 Maxim Monastirsky 2021-02-07 09:23:17 UTC
*** Bug 140199 has been marked as a duplicate of this bug. ***
Comment 12 Xisco Faulí 2021-02-08 11:07:06 UTC
Verified in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: faadf530c22d1874640936b8554845d7ff36f263
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 13 Commit Notification 2021-02-09 11:33:19 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/593ab5fbedb3de3c62039affd69f3dcd30f56d8f

tdf#140151: sc_uicalc: Add unittest

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.