Bug 140409 - Zoom ignores the comment text
Summary: Zoom ignores the comment text
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.2.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Writer-Comments Weld-Writer-Comments
  Show dependency treegraph
 
Reported: 2021-02-14 14:52 UTC by xordevoreaux
Modified: 2021-11-02 01:37 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (57.65 KB, image/png)
2021-02-14 14:53 UTC, xordevoreaux
Details
screenshot zoomed out (80.55 KB, image/png)
2021-02-14 15:07 UTC, xordevoreaux
Details
7.0.4 vs. 7.2 (96.15 KB, image/png)
2021-02-15 14:31 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xordevoreaux 2021-02-14 14:52:53 UTC
Description:
I must zoom in to read a document because of my eyesight, but when I do, comment text gets smaller and smaller the more I zoom.

Steps to Reproduce:
1. Launch Windows LO Writer
2. Type something
3. Add a comment to what you typed
4. Zoom in

Actual Results:
Comment text gets smaller and smaller the more you zoom in

Expected Results:
Comment text should behave like the rest of the document


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 28555fc345ac2ccdda0e4e0f3c812c646befe68b
CPU threads: 8; OS: Windows 10.0 Build 21313; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 1 xordevoreaux 2021-02-14 14:53:21 UTC
Created attachment 169732 [details]
screenshot
Comment 2 xordevoreaux 2021-02-14 15:07:03 UTC
Created attachment 169733 [details]
screenshot zoomed out

The opposite also happens. Zooming out makes the comment text huge.
Comment 3 Julien Nabet 2021-02-14 20:46:01 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.

When zooming in the comment becomes smaller but it's not its inner size which becomes smaller, it's its size compared to the rest.
Anyway, there's indeed a pb here.
Comment 4 Timur 2021-02-15 12:24:39 UTC Comment hidden (obsolete)
Comment 5 xordevoreaux 2021-02-15 13:31:56 UTC Comment hidden (obsolete)
Comment 6 Heiko Tietze 2021-02-15 14:31:15 UTC
Created attachment 169766 [details]
7.0.4 vs. 7.2

Confirming that master behaves differently and unexpected.
Comment 7 Timur 2021-02-15 14:41:29 UTC
(In reply to mwtjunkmail from comment #5)
> (In reply to Timur from comment #4)
> > This is not a bug but request for enhancement. 
> > In similar cases it's wrong to just confirm a bug that would assume general
> > change based on a single or few requests. I guess only option could be
> > available. 
> > I add UX.
> 
> Sorry, but this is a bug. This behavior never occurred before. It's gross,
> it needs to go away.

Thanks. I couldn't check myself and I concluded wrong from the description. 
So it needs to be said if it worked before (ie regression).
Comment 8 Timur 2021-02-15 14:42:41 UTC Comment hidden (obsolete)
Comment 9 xordevoreaux 2021-02-16 23:04:08 UTC
Zooming at all in LO Writer on pages with lots of comments not only has the text size not following with the zoom size, but zooming at all is crazy-slow.

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 2c8ffa41ec8e1ab2af95d5e033a445c17d29cf5a
CPU threads: 8; OS: Windows 10.0 Build 21313; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 10 raal 2021-02-17 20:23:12 UTC
This seems to have begun at the below commit.
Adding Cc: to Caolán McNamara ; Could you possibly take a look at this one?
Thanks
linux-64-7.2$ 
64bb6290805110805ac8c464f9272226504e3fde is the first bad commit
commit 64bb6290805110805ac8c464f9272226504e3fde
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Sat Feb 6 13:27:23 2021 +0100

    source sha:69c546e1e7a697217f273baa7c1729ff823efd76

commit	69c546e1e7a697217f273baa7c1729ff823efd76	[log]
author	Caolán McNamara <caolanm@redhat.com>	Fri Dec 04 16:30:31 2020 +0000
committer	Caolán McNamara <caolanm@redhat.com>	Sat Feb 06 12:16:04 2021 +0100
tree	4533c38b84d1cd57f86094ac816f0eb7c526ade1
parent	2c61782812b1b8b382dd48a04a712da9eaeb4685 [diff]

weld annotation window
Comment 11 Caolán McNamara 2021-02-18 20:47:06 UTC
The font size of the labels changes, but not that of the multiline editengine
Comment 12 Commit Notification 2021-02-19 09:09:07 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f73289763452f2f32993d5defb79ce69ba8f5188

tdf#140409 Comment text ignoring zoom size

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Julien Nabet 2021-02-19 09:30:42 UTC
On pc Debian x86-64 with master sources updated today (including Caolán's patch), I confirm I don't reproduce the bug.

Thank you Caolán!
Comment 14 Commit Notification 2021-02-19 14:56:41 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d3765ec240eca85a72c6940a5e19bb82d65cad03

Related: tdf#140409 scale the menubutton like the other widgets

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.