Bug 140414 - Crash pressing Ctrl-K in input line in Calc
Summary: Crash pressing Ctrl-K in input line in Calc
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.0.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.2.0 target:7.1.1
Keywords: haveBacktrace, needUITest
: 140191 140295 140412 140782 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-02-14 18:23 UTC by Regina Henschel
Modified: 2021-03-26 07:58 UTC (History)
5 users (show)

See Also:
Crash report or crash signature: https://crashreport.libreoffice.org/stats/crash_details/45847572-7111-45af-a4c3-d2990f72f211
Regression By:


Attachments
Document to reproduce the crash (8.66 KB, application/vnd.oasis.opendocument.spreadsheet)
2021-02-14 18:23 UTC, Regina Henschel
Details
Callstack VS2019 (2.52 KB, text/plain)
2021-02-14 18:24 UTC, Regina Henschel
Details
bt with debug symbols (13.83 KB, text/plain)
2021-02-14 19:21 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2021-02-14 18:23:14 UTC
Created attachment 169738 [details]
Document to reproduce the crash

Open attached file.
Set cell cursor to A1.
Click into input line.
Press Ctrl+K => Crash

The error message is
Exception thrown: read access violation.
**this** was 0x1E8.

It crashes in Version: 7.1.0.3 (x64) / LibreOffice Community
Build ID: f6099ecf3d29644b5008cc8f48f42f4a40986e4c
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: de-DE (en_US); UI: en-US
Calc: CL

It does not crash in Version: 6.4.5.0.0+ (x64)
Build ID: 70a2071ce91b71326659e645dd97996262ea309a
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: GL; VCL: win; 
Locale: de-DE (en_US); UI-Language: en-US
Calc: threaded
LO 6.4.5 does nothing.

Expected: The hyperlink-dialog opens and the hyperlink can be edit. At least LibreOffice should not crash.
Comment 1 Regina Henschel 2021-02-14 18:24:51 UTC
Created attachment 169739 [details]
Callstack VS2019
Comment 2 Julien Nabet 2021-02-14 19:21:36 UTC
Created attachment 169740 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I could reproduce this.

I can reproduce this on a brand new file.
Comment 3 Julien Nabet 2021-02-14 20:21:33 UTC
I gave a try with
https://gerrit.libreoffice.org/c/core/+/110884

but as I put in comment, I don't know if it's the right fix or a bandaid.
Comment 4 Commit Notification 2021-02-15 09:13:00 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/cbb0f58ef18f9a6bc135c4085f519c95e6fb663d

tdf#140414: fix Crash pressing Ctrl-K in input line in Calc

It will be available in 7.1.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2021-02-15 09:14:13 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3aad3955650edb543d74a4c1e3ebdb1f4d3940b7

tdf#140414: fix Crash pressing Ctrl-K in input line in Calc

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2021-02-15 14:08:40 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/5c89695f3885ec2e7cd00eaf56a46a7f00c44883

tdf#140414 add getting mouse pos to EditViewCallbacks

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2021-02-17 09:30:20 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-7-1-1":

https://git.libreoffice.org/core/commit/9b48f981807995d932ee36bd1f5b7972c72f871d

tdf#140414: fix Crash pressing Ctrl-K in input line in Calc

It will be available in 7.1.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 raal 2021-02-20 22:32:41 UTC
*** Bug 140412 has been marked as a duplicate of this bug. ***
Comment 9 Xisco Faulí 2021-03-03 22:55:29 UTC
*** Bug 140782 has been marked as a duplicate of this bug. ***
Comment 10 Aleksandar Kondic 2021-03-07 07:16:50 UTC
*** Bug 140295 has been marked as a duplicate of this bug. ***
Comment 11 Richard_416282 2021-03-08 02:07:36 UTC
Don't know who "UI" is, but ordinary user with similar problem with the 7.1.1.1 release from Feb 26 or so download with default options.

I fell upon this bug, but there was no specific crash dump submitted. 

So, after having my BugReport flagged as "Duplicate" of the "Cntl-K" failure, even though, it was not with a keyboard action, but with a mouse click, I suppose it invoked the same chunk of code.

What do I know, I'm used to punched cards and dropped decks of cards where the sequence numbers from columns 72 to 80 would go out of order during the compile phase of the source code.

So, I click on the download link for EN-US, x64 binaries , this time for 7.1.

What downloads on March 03, but the file for LibreOfficeInstaller version 7.1.1. Quirky, but close enough.

Upon Install however, the Object code for 7.1.1.2 installs where the old 7.1.1.1 used to be, then cleans up after itself. 

System Reboot later (for registry, re-sync), and now am running 7.1.1.2 build fe0b....4676 implementing fix for this bug (3 weeks ago).

Voila.

Test with vanilla spreadsheet, it appears to work(leaving warranty owk for when 7.2 gets released), but for now , on x64 system with 2 GB RAM, and 50GB HDD, along with EN keybord, but having multi-smbbol key faces (our Bi-Lingual beaureaucrats at work).

So, for this single user it appears to be working (https://git.libreoffice.org/core/+/refs/tags/libreoffice-7.1.1.2-buildfix1).

Your Mileage Might Vary.
Comment 12 Buovjaga 2021-03-08 06:15:35 UTC
(In reply to Richard_416282 from comment #11)
> Don't know who "UI" is

https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Keywords#needUITest
Comment 13 fe60 2021-03-26 07:58:27 UTC
*** Bug 140191 has been marked as a duplicate of this bug. ***