Bug 140499 - wrong page number in footer when printing two-page selection of longer document
Summary: wrong page number in footer when printing two-page selection of longer document
Status: RESOLVED DUPLICATE of bug 118378
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-18 11:30 UTC by Ulrich Windl
Modified: 2021-02-18 16:13 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrich Windl 2021-02-18 11:30:40 UTC
I selected text worth two pages in a longer document. The selection was not at the end of the document.
The document had a footer showing <<"current page" / "total pages">>.
When printing the two pages, the footer on both pages said << 136 / 136 >>.
Comment 1 Ulrich Windl 2021-02-18 11:33:24 UTC
The selection would correspond to a range from <<130 / 136>> up to <<131 / 136>>, just for clarity.
Comment 2 [REDACTED] 2021-02-18 12:15:32 UTC
Use "130,131" under "Pages" in section "Range and Copies" of the print dialog and you should get the correct numbering of pages as "130/136" and "131/136"

I'm not sure whether this is a bug or solely due to the fact that you try to print a text "selection" (confirming that your description is correct for this case on

Version: 7.1.0.3 / LibreOffice Community
Build ID: f6099ecf3d29644b5008cc8f48f42f4a40986e4c
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: kf5
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

)
Comment 3 Ulrich Windl 2021-02-18 14:28:38 UTC
When I wrote "text worth two pages" I mean that the section selected did not align with whole pages.  So printing the two pages that contain the selection would be a work-around, but still a different thing.
So what did I expect: Either seeing the original page and total numbers, but as the text got "re-flown" to start at the top of the first page, seeing <<1 / 2>> and <<2 / 2>> is probably what I should expect.
Probably there is no perfect solution, but showing two identical page numbers probably not the best alternative.
Comment 4 Timur 2021-02-18 16:13:32 UTC
Looks like a duplicate. 
If not, please explain why. 
Rule of thumb is search before reporting. 
Another best practice is to attach minimal sampke.

*** This bug has been marked as a duplicate of bug 118378 ***