Bug 140504 - Cursor doesn't change into hand-cursor when CTRL + Hover over Hyperlink
Summary: Cursor doesn't change into hand-cursor when CTRL + Hover over Hyperlink
Status: RESOLVED DUPLICATE of bug 138545
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Hyperlink
  Show dependency treegraph
 
Reported: 2021-02-18 12:41 UTC by bugzilla2
Modified: 2021-07-07 11:52 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot-Comparrison explaining the difference between 7.0 and 7.1 series (26.52 KB, image/png)
2021-02-18 12:42 UTC, bugzilla2
Details
Demo-document with hyperlink (10.03 KB, application/vnd.oasis.opendocument.text)
2021-02-18 12:43 UTC, bugzilla2
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugzilla2 2021-02-18 12:41:53 UTC
Description:
In Writer 7.1.x, if you hover over a link with pressed CTRL Key, the Cursor doesn't change into the hand-cursor anymore, like it did in previous versions.

Steps to Reproduce:
1. Open attached test-document
2. Hover over the Link "Headline" with pressed CTRL Key

Actual Results:
No hand-cursor shown

Expected Results:
Cursor should be changed into hand-cursor when hovering the Link with pressed CTRL Key.


Reproducible: Always


User Profile Reset: No



Additional Info:
PS: This happens in 7.1.0.2 and 7.1.1.1, but since none of them was selectable above, I picked 7.1.0.3 in Meta-Info.
Comment 1 bugzilla2 2021-02-18 12:42:44 UTC
Created attachment 169854 [details]
Screenshot-Comparrison explaining the difference between 7.0 and 7.1 series
Comment 2 bugzilla2 2021-02-18 12:43:32 UTC
Created attachment 169855 [details]
Demo-document with hyperlink
Comment 3 Irene H 2021-02-27 21:52:42 UTC
I was able to reproduce this bug with both the following versions

Version: 7.1.0.3 (x64) / LibreOffice Community
Build ID: f6099ecf3d29644b5008cc8f48f42f4a40986e4c

&

Version: 7.1.1.1 (x64) / LibreOffice Community
Build ID: 575c5867c4cc13d7ae78f9ce39a54a52ed38c769
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: en-US (en_DE); UI: en-GB
Calc: CL


This bug also happens with non-index hyperlinks
1. Insert a Hyperlink (Insert > Hyperlink or Ctrl + K)
2. Add any url and Text 
3. Click Okay
4. Hover over the link with Ctrl pressed


Additional Information:
- Clicking on the hyperlink still opens the link / jumps to the right part of the document
- From the reporter screenshot I assume that a german locale was used, so the locale seems unrelated to the bug
Comment 4 pavlog 2021-03-14 15:20:42 UTC
I can also confirm it in

Version: 7.2.0.0.alpha0+ (x64)
Build ID: ecb916667b633f8647790e040226b093760e6cfe
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL


Version: 7.1.0.3 (x64) / LibreOffice Community
Build ID: f6099ecf3d29644b5008cc8f48f42f4a40986e4c
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 5 bugzilla2 2021-07-03 10:23:30 UTC
Bug still exists in 

Version: 7.1.4.2 (x64) / LibreOffice Community
Build ID: a529a4fab45b75fefc5b6226684193eb000654f6
CPU threads: 12; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: threaded
Comment 6 Robert Großkopf 2021-07-03 14:11:40 UTC
Bug doesn't appear in LO 7.0.*. So it's a regression.
Comment 7 Michael Weghorn 2021-07-03 20:26:58 UTC
Bibisected to:

commit 5ab17ad2696aeb8acfc21cd2442908b785a53e86
Author: Jim Raykowski
Date:   Mon Jul 27 19:42:17 2020 -0800

    tdf#38093 Writer outline folding - ctrl + click toggle visibility
    
    Patch 3/6 that breaks down https://gerrit.libreoffice.org/c/core/+/96672
    
    Adds ctrl + mouse-click to toggle outline content visibility. Right
    click includes sub levels. Outline content visibility of sub levels is
    set to that of the clicked outline content toggled visibility.
    
    Change-Id: I428b3c683bec48bec147385dcdb1708e1f28d791
    Reviewed-on: https://gerrit.libreoffice.org/c/core/+/99654
    Tested-by: Jenkins
    Reviewed-by: Mike Kaganski


Adding CC: to Jim Raykowski
Comment 8 Jim Raykowski 2021-07-07 04:20:59 UTC
I think this is a duplicate of Bug 138545
Comment 9 Michael Weghorn 2021-07-07 06:17:27 UTC
(In reply to Jim Raykowski from comment #8)
> I think this is a duplicate of Bug 138545

Indeed. It works fine with current master.

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 17bc5794d6acd38304653dc78b95f9f772893ca7
CPU threads: 12; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: en-GB (en_GB.UTF-8); UI: en-US
Calc: threaded

*** This bug has been marked as a duplicate of bug 138545 ***
Comment 10 bugzilla2 2021-07-07 11:52:24 UTC
Im not really sure if this is a dupe or just a bug with the same "effect".

Because Bug 138545 belongs to a different version tree (7.2 instead of 7.1) and different commits thats caused the problem.

Since there are three more minor versions of 7.1 to come, it would be great to have that fixed in 7.1.5 too.