Bug 140594 - Screen reader does not announce new spinbox value when changing it with up/down key (Windows)
Summary: Screen reader does not announce new spinbox value when changing it with up/do...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Michael Weghorn
URL:
Whiteboard: target:7.3.0 target:7.2.0.0.beta2 tar...
Keywords: accessibility, regression
Depends on:
Blocks: a11y
  Show dependency treegraph
 
Reported: 2021-02-22 11:20 UTC by Michael Weghorn
Modified: 2021-08-16 18:01 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Weghorn 2021-02-22 11:20:24 UTC
This was originally reported on the accessibility mailing list here: https://listarchives.tdf.io/i/S8RCAJc7eJgj2-XFxfmxYTPg

New values for spinboxes is not announced when changed using up/down keys.

Sample steps to reproduce:

0. enable NVDA or JAWS screen reader
1. start LO Calc
2. go to "Format" -> "Cells" -> "Numbers" tab
3. press tab key a few times until the "Decimal places" spinbox is active (and current value is read)
4. press the "up" key to increase the value by one

Actual behaviour:

* the value is increased by one
* but the new value is not announced by the screen reader

Expected behaviour:

The new value should be announced by the screen reader, just as happens e.g. when typing a value manually, e.g. pressing the key "4" instead of using the up key.

Side note: It works as expected with the gtk3 VCL plugin on Linux (which presumably uses native Gtk widgets).

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 75894d5c6afd3f4d206b50c529d83db9c1f8232d
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded
Comment 1 Michael Weghorn 2021-02-22 11:21:20 UTC
Setting to new, since it was originally reported on the accessibility mailing list and I can reproduce.
Comment 2 Michael Weghorn 2021-07-07 13:03:37 UTC
While looking into this, I realized it's a regression from

        commit 2a694f9e0e7789b4b3b792a9eedd29366fa10c1c
        Date:   Wed May 6 14:08:07 2020 -0400
    
            lok: fix the window type of the formatted field control


Pending fix: https://gerrit.libreoffice.org/c/core/+/118568
Comment 3 Commit Notification 2021-07-07 13:57:23 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/cdc752fd5e5b3bf97043b9542867d84827614f2c

tdf#140594 Create proper window peer for FORMATTEDFIELD

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2021-07-07 19:51:12 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/1ac29daf64273814227e81e8c3f4e519e0809e57

tdf#140594 Create proper window peer for FORMATTEDFIELD

It will be available in 7.2.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2021-07-07 19:51:24 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/1e7f4ecdfbb30cdf35501292ced01388b8d24647

tdf#140594 Create proper window peer for FORMATTEDFIELD

It will be available in 7.1.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2021-07-12 20:01:14 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "libreoffice-7-1-5":

https://git.libreoffice.org/core/commit/3bb93f85a32973b492d2d0eb61e1f71269be2fbc

tdf#140594 Create proper window peer for FORMATTEDFIELD

It will be available in 7.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.