Bug 140939 - Proposal to improve the index function in Writer.
Summary: Proposal to improve the index function in Writer.
Status: RESOLVED DUPLICATE of bug 30940
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-10 18:17 UTC by Christian Tremblay
Modified: 2021-04-13 17:18 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Tremblay 2021-03-10 18:17:40 UTC
Description:
I would like to propose an improvement to the lexical index or custom index function.
There can only be one lexical index.Wouldn't it be possible to create several lexical indexes (proper nouns and notions for example)?
Or, would it be possible for a custom index to have the same characteristics as a lexical index, in particular, that the occurrences of the same entry (a notion for example) could appear on the same line with the page numbers, as for a lexical index? A graph, a table or a photo usually has only one occurrence, but a concept or a notion usually has several occurrences. 
Currently, for a given concept I will have to manually delete all duplicate lines and then group the page numbers where that concept appears at the end of the line.  I think this would be a big improvement.

Actual Results:
Insert an index :
If lexical index :
- Will you create a new lexical index ?
Or if costum index
- Created from word or concepts ? (as lexical index)

Expected Results:
For slightly large documents, I would like create several lexical index.


Reproducible: Always


User Profile Reset: No



Additional Info:
Nothing
Comment 1 Christian Tremblay 2021-03-10 18:30:08 UTC
What I would like to see (several times)
Index des noms
Abdou Diouf	23, 398
Académie d’Études Économiques de Bucarest	46, 74
Académie Européenne de Bozen/Bolzano	74
Académie française	429
ACAREF (Académie Africaine de Recherche et d'Etudes Francophones)	51, 79, 402
Afghanistan	140
Afrique	51 sv, 78 sv, 142, 146, 200 sv, 203 sv, 252, 348, 376, 380, 397, 400, 402 sv, 409, 412, 481
AIIC	25, 40, 59 sv
Alain Minc	154, 242
Alexandre Wolff	55

What I don't want to see with words, concepts or notions:
Index des notions index of notions
Plurilinguisme	1
Plurilinguisme	1
Plurilinguisme	1
Plurilinguisme	1
Plurilinguisme	1
Plurilinguisme	1
Plurilinguisme	1
Plurilinguisme	1
Plurilinguisme	1
Plurilinguisme	1
Plurilinguisme	1
Identité	6
Charte européenne des langues régionales et minoritaires	6
Soft power	6
Francophonie	6
Souveraineté	7
Souveraineté	7
Souveraineté	7
Souveraineté	7
Plurilinguisme	13
Plurilinguisme	13
Plurilinguisme	13
Rapport ELAN	13
Comment 2 Dieter 2021-03-25 08:18:23 UTC
(In reply to Christian Tremblay from comment #0)
> There can only be one lexical index.Wouldn't it be possible to create
> several lexical indexes (proper nouns and notions for example)?
I think this is bug 30940. So let's reduce this bug to your second idea

> Or, would it be possible for a custom index to have the same characteristics
> as a lexical index, in particular, that the occurrences of the same entry (a
> notion for example) could appear on the same line with the page numbers, as
> for a lexical index?
I'm not sure, if I understand everything. Could you please attach a sample document with an alphabatical index and an User-Defined Index to make it easier to compare and understand your idea?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it)
Comment 3 Christian Tremblay 2021-03-25 21:58:29 UTC
What I would like to have, it's a lexical index for proper names and a lexical index for notions and concepts. Presently, this is impossible because there can only be one lexical index.
For example :

Index of proper names
Abdou Diouf	23, 398
Académie d’Études Économiques de Bucarest	46, 74
Académie Européenne de Bozen/Bolzano	74
Académie française	429
ACAREF (Académie Africaine de Recherche et d'Etudes Francophones)	51, 79, 402
Afghanistan	140
...

Index of notions
Multilingualism 9, 13, 65
Identity 25,42, 87
Soft power 101,125
...

Lexical index and costum index don't work in the same way at all.
Lexical index is alphabetical, as costum index follows order of entries and pages.
What would be really useful is to be able to create more than one lexical index.
Comment 4 QA Administrators 2021-03-26 04:21:50 UTC Comment hidden (obsolete)
Comment 5 Dieter 2021-03-26 05:32:11 UTC
(In reply to Christian Tremblay from comment #3)
> What would be really useful is to be able to create more than one lexical
> index.
This is bug 30940.

*** This bug has been marked as a duplicate of bug 30940 ***
Comment 6 Christian Tremblay 2021-04-12 21:52:47 UTC
My "second idea" is to make a personal index do what a lexical index already does. It is the same problem that we propose to solve by a different way. So bug 140939 is the same as bug 30940. The two bugs should be merged.
Comment 7 Dieter 2021-04-13 17:18:38 UTC
(In reply to Christian Tremblay from comment #6)
> The two bugs should be merged.
This is done by marking the later one as duplicate. Please add your ideas in a comment of bug 30940