Bug 140970 - FILE-PROPERTIES: Focus should be in input field, if you add new property
Summary: FILE-PROPERTIES: Focus should be in input field, if you add new property
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.4.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: File-Properties
  Show dependency treegraph
 
Reported: 2021-03-12 08:53 UTC by Ulrich Windl
Modified: 2021-05-20 12:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrich Windl 2021-03-12 08:53:29 UTC
Trying to reproduce some older issue, I found this one (for German language):
When I tried to add the user-defined property "Arbeit", the following happened.
I opened File->Properties ("Eigenschaften" in German), then user-defined properties ("Benutzerdefinierte Eigenschaften").
The I pressed "Eigenschaft hinzufügen" (add property).
A new entry ("Name", "Art", "Wert" (name, type, value) appears BUT the input focus is NOT on "Name" (as users might expect).
As soon as I type 'A' (Shift+a), the whole dialog closes!
That seems true because of those three issues:
1) The focus is not on the new input field(s)
2) "Abbrechen" (abort) has 'A' as hot key
3) Shift+a, and not ALt+A (or Alt+Shift+a) triggers the abort.

All in all just bad usability.
Comment 1 Dieter 2021-03-27 11:33:29 UTC
Ulrich, I think, we have two different issues here:
a) Dialog closes, if you press Shift+A
b) Focus should be on input-field

I think b) should reported in a separate bug. I don't know, if this is a bug or enhancement request, but I can confirm the actual situation.

I could reproduce problem a), but not in SafeMode => have you also tested in SafeMode?
=> NEEDINFO
Comment 2 Dieter 2021-03-27 11:34:08 UTC
(In reply to Dieter from comment #1)
> I could reproduce problem a), but not in SafeMode => have you also tested in
> SafeMode?

Tested with
Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: f96004096268f5e71120678e32fc8c74055819aa
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: default; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: threaded
Comment 3 Ulrich Windl 2021-03-29 08:29:48 UTC
For me Safe Mode didn't make a difference. Are you sure you did the same thing in both modes?
For the issues:
I think the Real Problem is that Shift+A is used as "hotkey" (when Alt+A should be the hotkey).
And Shift+A seems to loose the hotkey property when the cursor is placed in an input field.
Finally usability would be much better if the cursor were placed into the first input field (that is required anyway).

While these could be three different, but related bugs, I think on person could fix all three at the sample place with little effort, so maybe it's still valid to have only one bug report for those
Comment 4 Dieter 2021-04-11 13:42:39 UTC
Tested again with

Version: 7.1.2.2 (x64) / LibreOffice Community
Build ID: 8a45595d069ef5570103caea1b71cc9d82b2aae4
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: default; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: threaded

Result:
1. I confirm, that focus is not on new input field

so status NEW is O. K. and let's focus this bug on that topic

I can also confirm, that Shift+A and also "a" is assigned to "Abbrechen" (but ALT+A works also). I have a similar result in Menu "Datei"; Shift+G or "g" opens Eigenschaften (Properties) dialog

But I'm not longer sure, if this is a bug or the expected behaviour; I couldn't find informations in LO Help, but general rule seems to be:
1. If a command or menu entry is selectrd you can use the single character
2. If the sursor is active you have to use ALT+Character
If you still think, it's a bug you should open a different report.