Bug 140992 - Direct input through copy and paste to table is lost
Summary: Direct input through copy and paste to table is lost
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
7.1.0.3 release
Hardware: All All
: high major
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.3.0 target:7.2.2 target:7.1.7
Keywords: bibisected, bisected, regression
: 143414 143625 143936 144745 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-03-12 21:19 UTC by Fred
Modified: 2021-10-01 20:31 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fred 2021-03-12 21:19:56 UTC
Description:
When copying and pasting into a Base table the data is lost. 
Create a table in design view: 
Fields: ID - Integer, AutoValue - yes, primary key 
My_Notes - Text (VARCHAR), length 100
Save it.
Open it, then try to paste anything into it.
The pasted value is seen.
Enter, or go to the next record and note the value is lost.
Even if you save the table, the value is lost.


Steps to Reproduce:
1.Create a table in design view: 
Fields: ID - Integer, AutoValue - yes, primary key 
My_Notes - Text (VARCHAR), length 100
Save it.
Open it, then try to paste anything into it.
The pasted value is seen.
Enter, or go to the next record and note the value is lost.
Even if you save the table, the value is lost.

2.
3.

Actual Results:
Pasted data is lost.

Expected Results:
Pasted data should remain in the table field.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
LibreOffice Ver 7.1.1.2 Build fe0b08f4af1bacafe4c7ecc87ce55bb426164676
and in prior version(s)
Windows 10.0 Build 18363
Comment 1 Fred 2021-03-27 17:17:39 UTC Comment hidden (obsolete)
Comment 2 Robert Großkopf 2021-07-13 17:53:09 UTC
Could confirm the buggy behavior for all versions beginning with LO 7.1.0.3. Last version without this bug I installed here is LO 7.0.5.2 on OpenSUSE 15.2 64bit rpm Linux.

Write a word in Writer and copy this into clipboard.
Open a database.
Copy the content in a field of an existing row (or a new field).
Switch to next row.
Old content could be seen again (or: pasted content has been gone).

Seems the content is only pasted to the view of the table, not to the bounded field.
Comment 3 Alex Thurgood 2021-07-19 15:12:08 UTC
*** Bug 143414 has been marked as a duplicate of this bug. ***
Comment 4 Alex Thurgood 2021-08-10 13:59:11 UTC
*** Bug 143625 has been marked as a duplicate of this bug. ***
Comment 5 Robert Großkopf 2021-08-18 17:51:29 UTC
*** Bug 143936 has been marked as a duplicate of this bug. ***
Comment 6 Alex Thurgood 2021-09-27 09:22:09 UTC
*** Bug 144745 has been marked as a duplicate of this bug. ***
Comment 7 Aron Budea 2021-09-29 23:26:19 UTC
This can be reproduced in Linux with VCL plugin 'gen', and has started from the following commit, bibisected using repo bibisect-linux-64-7.1. Adding CC: to Caolán McNamara.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=a751d9c414fc63f36ae4b54b8adbaba042b31f60
author		Caolán McNamara <caolanm@redhat.com>	2020-07-01 17:00:44 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2020-07-02 20:22:05 +0200

weld FormattedControl
Comment 8 Xisco Faulí 2021-09-30 11:54:58 UTC Comment hidden (obsolete)
Comment 9 Caolán McNamara 2021-09-30 14:44:14 UTC
the Edit isn't getting flagged as modified, though if done through the context menu then the paste is detected as a modification
Comment 10 Commit Notification 2021-10-01 13:09:25 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/8606b25c7529a5e8d65b3c422edb8d74af0151c8

Resolves: tdf#140992 Paste/Cut should mark Edit as modified

It will be available in 7.1.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2021-10-01 13:44:53 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/236419fb117ce8cd96d181f0b1050d7bb6020a06

Resolves: tdf#140992 Paste/Cut should mark Edit as modified

It will be available in 7.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2021-10-01 15:12:47 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/097257d5e5ccf5026db42b8bb459dc78390dc9e5

Resolves: tdf#140992 Paste/Cut should mark Edit as modified

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2021-10-01 16:59:14 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-2-2":

https://git.libreoffice.org/core/commit/ce64c678e7dcc188f38304f0813d1c7895e6832f

Resolves: tdf#140992 Paste/Cut should mark Edit as modified

It will be available in 7.2.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Fred 2021-10-01 20:31:01 UTC
I am unable to test.

Windows Security (Microsoft Defender reports PUA:Win32/PiriformBundler when I try to install LibreOfficeDev_7.3.0.0.alpha0_Win_x64.msi downloaded from https://dev-builds.libreoffice.org/daily/master/current.html

--- Fred