Bug 141402 - It should be possible to define or modify Table Styles
Summary: It should be possible to define or modify Table Styles
Status: RESOLVED DUPLICATE of bug 105933
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-31 17:12 UTC by Christian Lehmann
Modified: 2021-04-15 06:29 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Lehmann 2021-03-31 17:12:34 UTC
Description:
There is a set of predefined table styles. However, of all the options commonly offered for styles, only 'Hide' is available; the others are greyed out, so one cannot even modify them. Consequence: if I want all of the tables of my document to have the same style (but none of the predefined styles), there is no way of using a general underlying format. Instead, I have to format each table individually.

Steps to Reproduce:
1. Hit CTRL-F5.
2. In the Styles bar, click 'Table Styles'.
3. At the bottom, choose 'All styles'.
4. Right-click one of the styles listed.

Actual Results:
All of the options are greyed out.

Expected Results:
All of them should be available. In particular, it should be possible to modify one.


Reproducible: Always


User Profile Reset: No



Additional Info:
Tables of a document share a set of layout features, but differ in such features like how many column heading lines there are etc. Therefore, not all table properties can be defined in a style. However, some of them can, like the alignment of the table, a certain border around it, a certain background color etc. The possibility to set them in a style would relieve the user from much work.
Comment 1 Dieter 2021-04-15 06:29:19 UTC

*** This bug has been marked as a duplicate of bug 105933 ***