Bug 141475 - Formatting aids color should either be editable or be automatically adjusted to stay in contrast with page background.
Summary: Formatting aids color should either be editable or be automatically adjusted...
Status: RESOLVED DUPLICATE of bug 80054
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.2.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-03 14:35 UTC by Tomasz Sztejka
Modified: 2021-04-18 10:57 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomasz Sztejka 2021-04-03 14:35:53 UTC
Description:
LibreOffice Writer.

Formatting aids (paragraph end, space, margins and etc.) can be invisible if background of a page is set to color close to that of the aids.

Formatting aids color is not user editable, neither by dialogs nor by expert configuration (search on "aids" returns no result) and stays fixed regardless of what is behind it.

In previous version most of them were black, what was consistent with 99% of text we do edit (black on color paper), so if text was visible they were visible too. In 7.0.2.2 it is a "light blue", possibly to let users to easily distinguish what signs on screen are their and what are automatic aids. The light blue color or dark gray are one of colors used by aids can be also selected by a user to be a page background. If user does such a selection the formatting aids are no longer visible.




Steps to Reproduce:
1.Open new document.
2.Type some text, enable formatting aids.
3.Set page background to blue, observe that paragraph marks and spaces, which are also blue are hardly visible;
3.Set page background to dark gray, observe that page text are boundary, which is also gray is hardly visible;

Actual Results:
Depending on Your monitor or eye-sight You may be still able to tell formatting aids apart of a background, but in many cases You won't be able to do that.

Expected Results:
Formatting aids should be visible regardless of what is behind them.


Reproducible: Always


User Profile Reset: No



Additional Info:
Even tough I do consider it to be a serious design bug (there was no thinking about: "What would happen if we let user to select any color as a background and then we draw a fixed color gray line over it mark something?") I think it is touching less that 1% of use scenarios so I decided to qualify it as an enhancement request.

1.There is no work around.

2.Easiest to implement: make the formatting aid color to be editable in "Writer->formatting aids" options dialog. This is however not an good work around;

3.Most user friendly solution: adapt formatting aids (including all other "automatic" elements like page borders), margins marks adapt to be in a contrast color to element they are drawn over. 

I'm not sure if this is still a case with Your drawing library, but in older days we had something called: "XOR drawing mode" which ensured that what we draw over something already existing on a drawing plane was always clearly visible. Not always nice looking, but always in high contrast. If this is a case with Your rendering library, switch to that mode. With a bit of play it can be made to have exact and predictable colors with white background and will ensure a good contrast with other backgrounds.
Comment 1 Dieter 2021-04-18 10:57:47 UTC

*** This bug has been marked as a duplicate of bug 80054 ***