Bug 141593 - Allow showing paragraph and character styles at once in style pane
Summary: Allow showing paragraph and character styles at once in style pane
Status: RESOLVED DUPLICATE of bug 90646
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Sidebar-Styles
  Show dependency treegraph
 
Reported: 2021-04-09 22:12 UTC by Eyal Rozenberg
Modified: 2021-05-04 14:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eyal Rozenberg 2021-04-09 22:12:15 UTC
In a typical workflow of mine, I repeatedly need to set a Character style shortly after having set a Paragraph style or vice-versa. At the moment, I am currently forced to switch style categories back-and-forth, which is a bit annoying.

It would be nice if I could choose to show _both_ Paragraph and Character styles in the sidebar at once (e.g. alphabetically; but even a hierarchy in which they each have their own root is fine).

Note that the annoyance is further exacerbated due to the non-persistence of the hierarchy state (bug 141592).
Comment 1 Eyal Rozenberg 2021-04-10 09:54:19 UTC
Note that, in MS Word, different categories of styles (paragraph, character etc.) are distinguished by a category icon next to the style name. This could work for us as well in a joint view.
Comment 2 Heiko Tietze 2021-05-04 14:21:36 UTC
Absolutely yes. Merging the styles into one deck is part of bug 90646 and hopefully done during this year GSoC.

*** This bug has been marked as a duplicate of bug 90646 ***