Bug 141606 - GTK3: holding left click opens context menu in Impress slide show
Summary: GTK3: holding left click opens context menu in Impress slide show
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
(earliest affected) release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
Depends on:
Blocks: GTK3
  Show dependency treegraph
Reported: 2021-04-10 13:01 UTC by bchemnet
Modified: 2022-11-07 19:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description bchemnet 2021-04-10 13:01:31 UTC
In an Impress slide show when the GTK3 overlay is active, holding a left click on a slide opens the right-click context menu after a few seconds.  This is annoying when drawing on a slide, as if I leave the pen down too long, then move, I often trigger a random menu option (most often advance to next slide).

A secondary effect is that if I release, without triggering a menu option, but then click somewhere else, a line is draw between the two click points.

Neither of these behaviors occurs if GTK3 is not being used, with an otherwise entirely identical install and profile.

Obviously this could be worked around by not holding the left click so long, but as I am usually drawing while presenting to a live audience and using the pointer also to point to objects, I trigger this bug fairly frequently.  I only recently worked out that it is GTK3-specific.

Steps to Reproduce:
1. For simplicity of demonstration, disable advance slide on click.
2. Start slide show.
3. Left click and hold.  See contex menu appear.
4. Turn on pen.
5. Left click and hold.  Release without trigger menu.
6. Left click briefly somewhere else.  See line appear between points.

Actual Results:
Right-click menu is opened by left click, and random lines are drawn.

Expected Results:
No context menu on left click and no random lines.

Reproducible: Always

User Profile Reset: Yes

OpenGL enabled: Yes

Additional Info:
Appears to affect all versions since introduction of GTK3 but I have not tested extensively.
Comment 1 Timur 2021-04-26 12:27:45 UTC
I confirm the behavior. Not sure if Lo bug or Gtk3. I'll set New so far. 
No repro Lo 4.1 oldest so looks like regression. Gtk3 Lo often doesn't run so bibisect would be hard or impossible.
Comment 2 Roman Kuznetsov 2022-11-07 19:01:22 UTC
No repro in

Version: (X86_64) / LibreOffice Community
Build ID: f7f0f39968e7b5630364d16d01c13ee015633be7
CPU threads: 4; OS: Linux 5.15; UI render: default; VCL: kf5 (cairo+xcb)
Locale: ru-RU (ru_RU.UTF-8); UI: en-US
Calc: threaded

possibly GTK3 only?
Comment 3 Caolán McNamara 2022-11-07 19:52:04 UTC
Holding it down generates a "LongPress" gesture, and there is a longpress handler in slideshow which shows the context menu.