Bug 141735 - Clone formatting while in text edit mode doesn't work as expected (Align to bottom becomes Align to top)
Summary: Clone formatting while in text edit mode doesn't work as expected (Align to b...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Clone-Formatting
  Show dependency treegraph
 
Reported: 2021-04-18 07:26 UTC by Patrick
Modified: 2022-04-14 16:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Video of the bug, as asked (837.45 KB, video/mp4)
2022-04-14 14:36 UTC, Patrick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick 2021-04-18 07:26:14 UTC
Description:
When using Paintbrush, the Format - Align Text is always reset to Align To Top.
PS. The Left/Center/Right works

Steps to Reproduce:
1. Make a Text two times
2. Format first text with Align to bottom
3. Format second text with Align to center
4. Paintbrush first to second
5. Check second, this is Align to top

Actual Results:
Align to top

Expected Results:
Align to bottom


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 7.1.2.2 (x64) / LibreOffice Community
Build ID: 8a45595d069ef5570103caea1b71cc9d82b2aae4
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: nl-BE (nl_BE); UI: nl-NL
Calc: threaded
Comment 1 Buovjaga 2022-04-14 13:49:13 UTC
I can't seem to have any effect. You are talking about two separate text boxes in Draw, right? Maybe you could record a video.
Comment 2 Patrick 2022-04-14 14:36:10 UTC
Created attachment 179562 [details]
Video of the bug, as asked

Comment # 1 on bug 141735 from Buovjaga
I can't seem to have any effect. You are talking about two separate text boxes
in Draw, right? Maybe you could record a video.
Comment 3 Patrick 2022-04-14 14:38:22 UTC
I have send you a video

Regards,
Patrick
Comment 4 Buovjaga 2022-04-14 15:02:01 UTC
Thanks, now I got it. If we are editing the text, the problem appears. If we are not editing the text, but just have the box selected, it clones OK.

Arch Linux 64-bit
Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 9a42c99d7b3e8a8429f14d7d851f3d186fa04594
CPU threads: 8; OS: Linux 5.17; UI render: default; VCL: kf5 (cairo+xcb)
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded Jumbo
Built on 14 April 2022
Comment 5 Buovjaga 2022-04-14 16:25:10 UTC
Already seen in 6.3. In 5.0 and earlier, it is not possible to clone the formatting between text boxes in any way. In older versions, Align bottom/top, center vertically are found under Table (when customising toolbar buttons).