Bug 141964 - FILEOPEN DOCX: Outline numbering not imported well.
Summary: FILEOPEN DOCX: Outline numbering not imported well.
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.3.0
Keywords: filter:docx
Depends on:
Blocks: DOCX-Bullet-Number-Outline-Lists 141966
  Show dependency treegraph
 
Reported: 2021-04-29 07:24 UTC by Justin L
Modified: 2021-07-26 17:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
chapterNumberingTortureTest5.docx: hand-tweaked to test edge cases. (6.01 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2021-04-29 07:24 UTC, Justin L
Details
chapterNumberingTortureTest5.pdf: exported by Word 2016 (7.00 KB, application/pdf)
2021-04-29 07:26 UTC, Justin L
Details
Comparison LibreOffice 7.2 master and MSO 2010 (76.92 KB, image/png)
2021-04-29 07:52 UTC, Xisco Faulí
Details
chapterNumberingTortureTest5_2010.jpg: screenshot from my Word 2010 (218.44 KB, image/jpeg)
2021-04-29 09:15 UTC, Justin L
Details
chapterNumberingTortureTest12.docx: can't cancel style numbering. (5.90 KB, patch)
2021-04-29 13:43 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Justin L 2021-04-29 07:24:13 UTC
Created attachment 171488 [details]
chapterNumberingTortureTest5.docx: hand-tweaked to test edge cases.

LibreOffice does not handle importing outline numbering very well.
1.) It doesn't inherit list level from prior style.
2.) It doesn't properly import level 9 - body text.

Steps to reproduce.
A.) Open the example document.
- There should not be a 3rd entry, but it should be "2nd.iii inherit only outline and list level."
- The second page items should not be numbered.


P.S. In Word 2003, the body-level numbering entries used the numbering's indenting, but in Word 2016 they don't.
Comment 1 Justin L 2021-04-29 07:26:18 UTC
Created attachment 171489 [details]
chapterNumberingTortureTest5.pdf: exported by Word 2016
Comment 2 Xisco Faulí 2021-04-29 07:52:47 UTC
Created attachment 171495 [details]
Comparison LibreOffice 7.2 master and  MSO 2010
Comment 3 Xisco Faulí 2021-04-29 07:53:05 UTC Comment hidden (no-value)
Comment 4 Xisco Faulí 2021-04-29 07:53:51 UTC Comment hidden (no-value)
Comment 5 Xisco Faulí 2021-04-29 07:54:34 UTC
and

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 6 Justin L 2021-04-29 08:17:39 UTC
(In reply to Xisco Faulí from comment #2)
> Comparison LibreOffice 7.2 master and  MSO 2010

Yikes: MS Office 2010 really looks like that? That is very different from both older 2003 and newer 2016, and is not at all correct.  (All the entries on the first page should be numbered.)
Comment 7 Justin L 2021-04-29 09:15:31 UTC
Created attachment 171497 [details]
chapterNumberingTortureTest5_2010.jpg: screenshot from my Word 2010
Comment 8 Justin L 2021-04-29 13:43:23 UTC Comment hidden (corrupt, no-value)
Comment 9 Justin L 2021-04-30 05:43:56 UTC
(In reply to Justin L from comment #8)
> Created attachment 171508 [details]
> chapterNumberingTortureTest12.docx: can't cancel style numbering.

Oops - I forgot to wrap the numbering in <numPr> in this example. And yet MS Word seems to honour it anyway. So this is not really a valid example document, although it does show a difference. Bug-for-bug...?
Comment 10 Justin L 2021-05-25 09:18:13 UTC
(In reply to Xisco Faulí from comment #2)
> Comparison LibreOffice 7.2 master and  MSO 2010
I just tested on MSO 2007, and it looks like what Xisco saw. So I think you just got your version mixed up. (I installed 2010 with SP1, so SP1 might also be a factor.)
Comment 11 Commit Notification 2021-07-08 11:17:08 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/bedd73ea578ad01171536ee90d22249fa221d2d6

tdf#141964 writerfilter CN: get paragraph and inherited listLevel

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2021-07-09 05:24:52 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a45876adc36a3764cfeadb1737e5dcfb7ffee9da

tdf#141964 writerfilter CN: listLevel 9 means no numbering

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2021-07-09 14:15:05 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ba7dc3413388449303745fdcbaa7e4ac478cd5a2

tdf#141964 writerfilter CN: also insert inherited listLevels

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2021-07-10 05:25:15 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/11211f2ff0a4d894f889874d46c6ba8be4d3dc39

tdf#141964 writerfilter CN: why ignore paragraph's listId?

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2021-07-10 17:49:34 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4450137924eb8626a57283e1ab4f4ad62dd2d595

related tdf141964 writerfilter CN: drop obsolete exception

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2021-07-14 07:07:23 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7c7dcdb5132b579485631e620c1a87cd9b3881e3

tdf#141964 writerfilter CN: only one style per outline level

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2021-07-14 15:31:01 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6d81084e4f5100b1c8204f30a91d7a5b79998508

tdf#141964 writerfilter CN: numId0 has different meaning for RTF

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 BogdanB 2021-07-16 18:54:51 UTC
It's solved now. Thanks for fixing this.

Verified in
Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: c6695a4aabeaae99174b7658f2b813788ecff7f0
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 19 Commit Notification 2021-07-26 17:25:06 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1441e001938d6a0b19743ef8170980238b88d350

tdf#143517 partial revert "tdf#141964 writerfilter CN: get para...

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.