Bug 141970 - More inexact numbers in drag-fill in 7.1 compared to 7.0
Summary: More inexact numbers in drag-fill in 7.1 compared to 7.0
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0 target:7.1.4
Keywords: bibisectNotNeeded, regression
Depends on:
Blocks:
 
Reported: 2021-04-29 11:17 UTC by Mike Kaganski
Modified: 2021-04-29 19:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Testing drag-fill (20.19 KB, application/vnd.oasis.opendocument.spreadsheet)
2021-04-29 11:17 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2021-04-29 11:17:20 UTC
Created attachment 171505 [details]
Testing drag-fill

After https://git.libreoffice.org/core/commit/d5ebe7c3089ab9f4d3fe0707169fc1ce024cdb70, drag-fill produces more inexact numbers compared to version 7.0.

In the attachment, there are integers from 1 to 1024 in row 1, and numbers from 1.1 to 1024.1 in row 1. For testing, I selected it all (Ctrl+Home; Shift+Ctrl+End), grabbed the small rectangle at the bottom right color of selection, and dragged to arbitrarily chosen row 1045. Then I exported to CSV (using en-US locale), and in a text editor counted number of matches for regex '\d+\.\d{2,}', which shows how many numbers with more than one digit after the decimal dot.

For v.6.4, there were 305.258 matches;
For v.7.0, there were  33.199 matches;
For v.7.1, there were 111.181 matches.

The decrease in 7.0 is due to https://git.libreoffice.org/core/commit/8f46501233c164ff91d77a7f5adf74ea16cd0165, and increase in 7.1 is due to https://git.libreoffice.org/core/commit/d5ebe7c3089ab9f4d3fe0707169fc1ce024cdb70. Reverting the latter decreases the number of problems down to 33.199 again.

So that last commit was not a great idea after all. The test is not exhaustive, of course; but it seems to be representative enough to consider revert of the commit.
Comment 1 Roman Kuznetsov 2021-04-29 12:33:38 UTC
Yep
Comment 2 Mike Kaganski 2021-04-29 12:54:13 UTC
For the record:

For Excel 2016, there were 1.024.915 (sic!) matches.
Comment 3 Commit Notification 2021-04-29 14:49:34 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/aa096331ba468f19951e43e2550105d4dcf50053

tdf#141970 Revert "tdf#129606: Round the mean of the two subtractions"

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2021-04-29 19:32:48 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/80d111c948d1553e9e0015738289b471cfe137f1

tdf#141970 Revert "tdf#129606: Round the mean of the two subtractions"

It will be available in 7.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.