Bug 142029 - EDITING FORMATTING Hidden columns revert to not hidden
Summary: EDITING FORMATTING Hidden columns revert to not hidden
Status: RESOLVED DUPLICATE of bug 128895
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.4.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-01 17:23 UTC by knute
Modified: 2021-06-11 10:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
spreadsheet with exposed columns BM through AMJ (17.01 KB, application/vnd.oasis.opendocument.spreadsheet)
2021-05-04 18:47 UTC, knute
Details

Note You need to log in before you can comment on or make changes to this bug.
Description knute 2021-05-01 17:23:06 UTC
Spreadsheets (.ods) that have hidden columns (i.e. from column J to column AMJ) will revert to unhidden starting with column BM through column AMJ. The columns from column J to column BL will remain hidden, but the columns from BM to the end will be visible.
Comment 1 m.a.riosv 2021-05-03 17:03:45 UTC Comment hidden (obsolete)
Comment 2 knute 2021-05-04 00:26:48 UTC
Always saved as file.ods
Comment 3 m.a.riosv 2021-05-04 08:06:31 UTC
Please can you attach a sample file where it happens.

And please don't mark as new your own reports, someone else might verify it.
Comment 4 knute 2021-05-04 18:47:21 UTC
Created attachment 171636 [details]
spreadsheet with exposed columns BM through AMJ

I added a text box in this sheet explaining the hidden columns that are no longer hidden. Columns BM through AMJ were formatted as hidden and the document was saved
Comment 5 QA Administrators 2021-05-05 03:46:12 UTC Comment hidden (obsolete)
Comment 6 Timur 2021-06-07 10:26:42 UTC
No repro with 6.4.
Reminds of column in bug 133327. 
Please upgrade LO at least to 7.0.6.
If you still repro please try to find minimal column range where it happens.
Comment 7 Timur 2021-06-11 09:04:37 UTC
Seems like duplicate. If not, please explain.

*** This bug has been marked as a duplicate of bug 128895 ***
Comment 8 mrkalvin 2021-06-11 10:26:14 UTC
You can reproduce this error by selecting from any column to the last one, for that click on the column header and press ctrl+shift+right arrow. Hide all selected columns and test.
Comment 9 mrkalvin 2021-06-11 10:27:06 UTC Comment hidden (obsolete)