Bug 142054 - Moving footnotes to end of documents messes up numbering
Summary: Moving footnotes to end of documents messes up numbering
Status: RESOLVED DUPLICATE of bug 43370
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.6.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected
Depends on:
Blocks:
 
Reported: 2021-05-03 10:49 UTC by bugzilla
Modified: 2021-05-05 11:19 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugzilla 2021-05-03 10:49:45 UTC
Description:
When footnotes in an existing Writer document are moved to the end of the document by changing the global Position setting, the numbering of the footnotes is changed.

Even when the settings for Footnotes (and Endnotes) is for consecutive numbering throughout the document, the numbering after moving them to the end of the document is per chapter, resulting in numerous footnotes with the same number on the same page.

Steps to Reproduce:
1.Create Writer document with several chapters and footnotes in various chapters, where the footnotes are automatically numbered consecutively throughout the document (not per page or per chapter). Save the document and close it.
2. Reopen the saved Writer document and go to Tools, then Footnes and Endnotes..., and change the "Position" option from "End of page" to "End of document" in the Footnotes tab.

Actual Results:
All Footnotes are moved to the end of the document. However, their numbering is no longer consecutive throughout the document. Instead, the numbering starts at 1 with each chapter.

Their is no apparent way to fix the wrong numbering, other than deleting all footnotes and re-entering them as endnotes.

Expected Results:
All footnotes are moved to the end of the document. Their numbering remains unchanged.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 5.1.6.2
Build ID: 1:5.1.6~rc2-0ubuntu1~xenial10
CPU Threads: 4; OS Version: Linux 4.15; UI Render: default; 
Locale: en-CA (en_CA.UTF-8); Calc: group
Comment 1 Timur 2021-05-04 14:21:26 UTC
Please attach a minimal sample document with explained steps within.
Please test with current LO, your 5.1 is too old.
Comment 2 Timur 2021-05-05 09:08:05 UTC
This was resolved long ago.
Please do not report bugs for such an old LO, just for downloadable LO.

*** This bug has been marked as a duplicate of bug 43370 ***
Comment 3 bugzilla 2021-05-05 11:19:46 UTC
This is the Libre Office version installed last month from my LTS Linux distribution. It was easy to download.

The bug is different from 43370, as that was about Footnotes created at the end of the document. Here we have Footnotes that were created throughout the document and then moved to the end.

Are you sure the fix for 43370 solves this situation as well?