Bug 142467 - Inserting series in Stock Chart Data Table crashes Writer (Fedora only?)
Summary: Inserting series in Stock Chart Data Table crashes Writer (Fedora only?)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
7.1.3.2 release
Hardware: All Linux (All)
: low normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.2.0 target:7.1.5
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-24 14:51 UTC by Kevin Suo
Modified: 2021-05-31 07:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
gdbtrace.log (33.74 KB, text/x-log)
2021-05-24 14:51 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2021-05-24 14:51:52 UTC
Created attachment 172298 [details]
gdbtrace.log

When testing bug 138556, I encounter the following crash:

1. New Writer, insert chart, right-click on the chart and change chart type to Stock Chart 1,OK.

2. Right-click on the chart and select Data Table.

3. Click on the cell of the 2nd column of 1st row (i.e., 9.1), then click "Delete Series" icon.

4. Click "Insert Series" icon.

-> Crash.

gdbtrace.log attached.

Version: 7.2.0.0.alpha1+ / LibreOffice Community
Build ID: 49af7e22e61c2e5d440ad55cd362388983e128ae
CPU threads: 4; OS: Linux 5.12; UI render: default; VCL: gtk3
Locale: zh-CN (zh_CN.UTF-8); UI: zh-CN
Calc: threaded

and 
Version: 7.1.4.0.0+ / LibreOffice Community
Build ID: b2fc048cb2d5f5bd1095a8110fa4a16a305a8acc
CPU threads: 4; OS: Linux 5.12; UI render: default; VCL: gtk3
Locale: zh-CN (zh_CN.UTF-8); UI: zh-CN
Calc: threaded

Fedora 33 X64.
Comment 1 Aritz Erkiaga 2021-05-24 15:38:00 UTC
Can confirm on Fedora 34. I haven't tested yet with 7.2 though... It might be already fixed.
Comment 2 Xisco Faulí 2021-05-25 07:17:30 UTC
I can't reproduce it in

Version: 7.2.0.0.alpha1+ / LibreOffice Community
Build ID: 42d2b2d55a27f11153ea1713737d93540a19211d
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 3 Xisco Faulí 2021-05-25 07:24:17 UTC
Not reproducible in

Version: 7.1.2.2 (x86) / LibreOffice Community
Build ID: 8a45595d069ef5570103caea1b71cc9d82b2aae4
CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: es-ES (es_ES); UI: es-ES
Calc: threaded

either
Comment 4 Timur 2021-05-25 08:54:31 UTC
Also no repro for me. 
So it's either Fedora or profile specific (please try on new profile).
Please see if regression and bibisect.
Comment 5 Aritz Erkiaga 2021-05-25 20:02:31 UTC
I can't reproduce it with builds from libreoffice.org, only with the ones from Fedora repos, so I'd say this is Fedora-specific.
Comment 6 Kevin Suo 2021-05-26 01:33:28 UTC
No need to delete the series to reproduce the crash - only inserting series is enough.

So, the steps are:

1. Insert chart in Writer, change chart type to Stock Chart 1.
2. Go to Data Table.
4. Click "Insert Series" icon on the Data Table toolbar.

-> Crash.

And this is why the UITest test_stock_chart13_insert_series fails on my system, see https://bugs.documentfoundation.org/show_bug.cgi?id=138556#c11
Comment 7 Xisco Faulí 2021-05-26 07:05:00 UTC
Hi Caolán,
does it crash on your end ? If I recall well, you use fedora as well...
Comment 8 Caolán McNamara 2021-05-26 10:34:33 UTC
I can reproduce in self-built 7-1 with gtk3 or gen. Not in 7-2, but I have 7-1 built with gcc and 7-2 with clang so it might not be a good comparison.
Comment 9 Kevin Suo 2021-05-26 10:46:23 UTC
(In reply to Caolán McNamara from comment #8)
The crash in my machine is also a self-build on Fedora 33, with the latest system updates.
Comment 10 Caolán McNamara 2021-05-26 11:40:46 UTC
I see it also in 6-4 so this has been going on for a while, trying to debug it
Comment 11 Caolán McNamara 2021-05-26 13:41:29 UTC
I have a workaround at least
Comment 12 Commit Notification 2021-05-26 15:00:19 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/0d3dd9d9f6f0e6236c8db8ebdea44c78854639a8

tdf#142467 crash on calling 'getInfoHelper' in final class

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Caolán McNamara 2021-05-26 15:29:36 UTC
that makes it not crash, backport to 7-1 in gerrit
Comment 14 Commit Notification 2021-05-26 18:06:11 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/e06f2bb00137655dbf6f0a8c8c2fc555720f4d3f

tdf#142467 crash on calling 'getInfoHelper' in final class

It will be available in 7.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Kevin Suo 2021-05-27 14:01:55 UTC
Confirm fixed on master, no crash anymore. and, the UITest as submitted in bug 138556 can now pass on my system.

Thanks Caolán.
Comment 16 Caolán McNamara 2021-05-27 14:23:02 UTC
sberg thinks this might be a gcc devirtualization bug and hopes to isolate it
Comment 17 Commit Notification 2021-05-31 07:58:29 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6cb1745c24c7651050e30216860c539fa13cc0e2

tdf#142467: Update comments with GCC bug ID

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.