Download it now!
Bug 142478 - [CRASH] searching on slide notes will crash Impress
Summary: [CRASH] searching on slide notes will crash Impress
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: highest critical
Assignee: Tomaz Vajngerl
URL:
Whiteboard: target:7.2.0 target:7.1.5
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2021-05-25 10:09 UTC by Marina Latini (SUSE)
Modified: 2021-06-09 13:31 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
bt with debug symbols (8.68 KB, text/plain)
2021-05-25 16:08 UTC, Julien Nabet
Details
Valgrind trace (116.29 KB, text/x-log)
2021-05-25 17:52 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marina Latini (SUSE) 2021-05-25 10:09:26 UTC
Description:
Issue initially reported on openSUSE https://bugzilla.suse.com/show_bug.cgi?id=1185797

the report was filed against a pptx presentation that can't be shared but the crash occurs on every search on pptx, not with special content.

While searching for an existing word in the slides notes Impress will crash instead of highlighting the existing word. 

Steps to Reproduce:
Steps for reproducing the crash:

1. open a new empty Impress document
2. save it as pptx
3. View -> Notes
4. Add some text in the notes area (for example "lorem")
5. press ctrl+f for opening the search toolbar
6. type "lorem" (or the text you entered on step 4)
7. click "find All"



Actual Results:
Impress will crash.

Expected Results:
The existing word is highlighted.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
------------------------------------------
7f619b5aaa0cab515cb62fc93f13f3b58c3a1a4e is the first bad commit
commit 7f619b5aaa0cab515cb62fc93f13f3b58c3a1a4e
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Sat Aug 29 13:47:30 2020 +0200

    source sha:2ebc26aeefefe33ee6180862509e4971ff2dfc6f
    
    source sha:2ebc26aeefefe33ee6180862509e4971ff2dfc6f

 instdir/program/libsdfiltlo.so | Bin 794504 -> 794504 bytes
 instdir/program/libsdlo.so     | Bin 9855728 -> 9855672 bytes
 instdir/program/setuprc        |   2 +-
 instdir/program/versionrc      |   2 +-
 4 files changed, 2 insertions(+), 2 deletions(-)
------------------------------------------

git bisect  log
# bad: [a0d29a846f1429ed8281d59f22bcfbdd13119279] source sha:91385bbc7cccfdf59f60a24eaf81894772134af0
# good: [36741205b2e1c9e51d58dff4d0b4ce9022013411] source sha:574c57090642347980d2395e1e183cc7b5c171ad
git bisect start 'origin/master' 'oldest'
# bad: [a41af4542f3c9bd81eba53ed8d55c23543d82ef7] source sha:487df0c8f307500029b06c89985a1148ebc784b5
git bisect bad a41af4542f3c9bd81eba53ed8d55c23543d82ef7
# good: [edf659cdbf7253f34342380f725f366d32cbd525] source sha:72186f02c118e9f5602e15c2bac9b3ac19987f93
git bisect good edf659cdbf7253f34342380f725f366d32cbd525
# good: [f68d1ea220dedd04dc2dc7226ea078fa20d8f004] source sha:7b314c6aceb51d01b9b4314764b0f5852b4fb655
git bisect good f68d1ea220dedd04dc2dc7226ea078fa20d8f004
# good: [b23d8719ba09fbfca6be25f7923ec37c3fd386e7] source sha:267da17721fae4708c0168b9a1e2917cae38628b
git bisect good b23d8719ba09fbfca6be25f7923ec37c3fd386e7
# bad: [907375103e8947c051df93652777b434c6d19050] source sha:f6c69ff33baa7de72a75afbf1de1f21f82adae47
git bisect bad 907375103e8947c051df93652777b434c6d19050
# good: [eb6e727cdb332ccb130fee3955d74495cbeaa724] source sha:dd2fcfcadcb3027f5ae727697be77943358cfd28
git bisect good eb6e727cdb332ccb130fee3955d74495cbeaa724
# good: [6f896d69822eb906beabc8931502c96509449c0b] source sha:2f297f4680a3b523005f4d4f762e195ba5f8912e
git bisect good 6f896d69822eb906beabc8931502c96509449c0b
# bad: [ec0c09fefbd47c4447191a8618ebbed7b6c49be2] source sha:40a9f3df19fc8ab3a75535bddeb423e70076a40e
git bisect bad ec0c09fefbd47c4447191a8618ebbed7b6c49be2
# good: [e9fa07f3ceab13cffd738d0333c6b59091fad8cd] source sha:0fb7ecb08dfce4b211ff91c062518dbe1b732bb1
git bisect good e9fa07f3ceab13cffd738d0333c6b59091fad8cd
# bad: [c15d1f2772482cf61309b09a9748c64f16b95412] source sha:9814c1f2edf56ecc0f31001db9234ef335488879
git bisect bad c15d1f2772482cf61309b09a9748c64f16b95412
# good: [08bbf7b63541f3c1054841cb35d6cc01509ee050] source sha:88e52e539eaf7981441ec3e042f321c2615919ca
git bisect good 08bbf7b63541f3c1054841cb35d6cc01509ee050
# bad: [6bee4904f5186974e29ef202740a7055420097f4] source sha:ac11b1f0311289c43f9a2c68e311de02cd0b53cf
git bisect bad 6bee4904f5186974e29ef202740a7055420097f4
# bad: [7f619b5aaa0cab515cb62fc93f13f3b58c3a1a4e] source sha:2ebc26aeefefe33ee6180862509e4971ff2dfc6f
git bisect bad 7f619b5aaa0cab515cb62fc93f13f3b58c3a1a4e
# first bad commit: [7f619b5aaa0cab515cb62fc93f13f3b58c3a1a4e] source sha:2ebc26aeefefe33ee6180862509e4971ff2dfc6f
------------------------------------------

https://git.libreoffice.org/core/+/2ebc26aeefefe33ee6180862509e4971ff2dfc6f
Comment 1 Marina Latini (SUSE) 2021-05-25 10:14:25 UTC
adding Tomaž Vajngerl in CC due to https://git.libreoffice.org/core/+/2ebc26aeefefe33ee6180862509e4971ff2dfc6f
Comment 2 Xisco Faulí 2021-05-25 10:19:23 UTC
Reproduced in

Version: 7.2.0.0.alpha1+ / LibreOffice Community
Build ID: 49af7e22e61c2e5d440ad55cd362388983e128ae
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

Steps to reproduce:
1. Open Impress
2. Type 'hello'
3. Go to View - Notes
4- Search 'hello'
5. Click on find all
Comment 3 Xisco Faulí 2021-05-25 10:35:49 UTC
it seems this problem is only reproducible searching on the notes view. Lowering priority a bit
Comment 4 Gerald Pfeifer 2021-05-25 10:45:23 UTC
(In reply to Xisco Faulí from comment #3)
> it seems this problem is only reproducible searching on the notes view.
> Lowering priority a bit

My original case was searching in the slides, and then simply going "next"
(or button down), "next",... and see it crash. 

Same in another document yesterday.

In neither case did I even have the notes view open (or was aware there
were notes to begin with).

Does that warrant increasing priority again?
Comment 5 Marina Latini (SUSE) 2021-05-25 11:08:12 UTC
(In reply to Xisco Faulí from comment #3)
> it seems this problem is only reproducible searching on the notes view.

it depends.

the problem is that in case of large presentations, if the word searched is both on slides content and notes LibreOffice will crash and  the general user can't understand why.

The problem happens when indeed the word searched is in the notes but for this case I spent quite some time in cleaning up the first internal document (51 slides) trying to understand the origin of the issue.

I agree that you need to be in the unlucky condition to search for a word that is also available from the notes, but, TBH, if you are using notes in a presentation, the probability to have a word both on slides and notes it's quite high.
Comment 6 Julien Nabet 2021-05-25 16:08:47 UTC
Created attachment 172333 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today + gtk3 rendering, I could reproduce this by using Xisco's comment.
Comment 7 Julien Nabet 2021-05-25 17:52:18 UTC
Created attachment 172337 [details]
Valgrind trace
Comment 8 Miklos Vajna 2021-06-01 13:10:27 UTC
Tomaz: could you please take a look? Thanks.
Comment 9 Commit Notification 2021-06-06 13:08:32 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3b75f9add7ed80e803b0771d86892d6ca0f47e71

tdf#142478 fix crash when searching and a viewshell change occurs

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2021-06-07 06:43:56 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7f059ce157da0de40a98f63f61d923cc67d93884

tdf#142478 add test that triggers find all and crashes

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2021-06-07 11:04:29 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/db6efbaf5f9d6ae818afccec6a9fab219268b621

tdf#142478 fix crash when searching and a viewshell change occurs

It will be available in 7.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Gerald Pfeifer 2021-06-09 09:47:08 UTC
I verified that the crash appears to be fixed with both

Version: 7.1.5.0.0+ / LibreOffice Community
Build ID: db6efbaf5f9d6ae818afccec6a9fab219268b621
CPU threads: 8; OS: Linux 5.12; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-7-1, Time: 2021-06-07_20:32:23

and

Version: 7.2.0.0.alpha1+ / LibreOffice Community
Build ID: b6a30a9db00f92eec7387a577321d65d47ff4af5
CPU threads: 8; OS: Linux 5.12; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-06-08_21:15:20


(Searching is still a bit strange when a word appears on the slide and
the notes in that one needs to hit "Next" to move from slide to notes or
vice versa and than again to actually go to the actual hit.)
Comment 13 Tomaz Vajngerl 2021-06-09 13:31:24 UTC
(In reply to Gerald Pfeifer from comment #12)
> (Searching is still a bit strange when a word appears on the slide and
> the notes in that one needs to hit "Next" to move from slide to notes or
> vice versa and than again to actually go to the actual hit.)

That should've been fixed too.. at least it is when I test it with my documents