Bug 142493 - FILEOPEN DOCX: Settings of character position and size changes in character style "Footnote Anchor"
Summary: FILEOPEN DOCX: Settings of character position and size changes in character s...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Styles-Character DOCX-Styles DOCX-Character
  Show dependency treegraph
 
Reported: 2021-05-26 09:19 UTC by Antonio
Modified: 2022-06-24 18:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
This is the template before saving as docx or doc. If I save as odt, no problem. (12.34 KB, application/vnd.oasis.opendocument.text-template)
2021-12-27 08:56 UTC, Antonio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Antonio 2021-05-26 09:19:16 UTC
Description:
Version: 7.0.6.2 (x64) Build ID: 144abb84a525d8e30c9dbbefa69cbbf2d8d4ae3b CPU threads: 2; OS: Windows 10.0 PRO Build 19042; UI render: Skia/Vulkan; VCL: win Locale: it-IT (it_IT); Interfaccia utente: it-IT Calc: threaded 

I want report to you a suspect of bug.
I begin from a model ott, in which there are styles of Footnote Anchor and Footnote characters.
I save as doc or docx.
When I reopen the document, the styles of Footnote Anchor and Footnote characters don't remain the same: in the panel "superscript", "raise/lower by" becames automatic or different and "relative font size" changes.
If I save the document as odt, all the styles remain the same when I open that document again.
This happens also with old portable versions.
Best regards to all.

Steps to Reproduce:
1.from model ott
2.set the styles of Footnote Anchor and Footnote characters
3.save as doc or docx and close the document
4.reopen the document and look at the styles of Footnote Anchor and Footnote characters: they are different from those saved

Actual Results:
I always have to set the styles again, before printing

Expected Results:
the styles should be the same reopening the document saved as doc or docx


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: it
Module: TextDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: yes
Comment 1 Dieter 2021-06-10 12:02:29 UTC
I tried to reproduce with the following steps
1. Open template
2. Insert some text and a footnote
3. Change character style of footnote anchor to "Footnote Anchor" and character style of footnote to "Footnote Characters"
4. Save as docx
5. Reload

Actual result: Character style of footnote anchor changes to "Default Character Style"; character style of footnote ist still "Footnote Characters"

Additional information
Same result, if you save as dotx.

So I can only confirm the first problem with

Version: 7.1.4.2 (x64) / LibreOffice Community
Build ID: a529a4fab45b75fefc5b6226684193eb000654f6
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Antonio, could you please retest and perhaps correct the steps? Thank you
=> NEEDINFO
Comment 2 Dieter 2021-06-27 11:07:43 UTC
(In reply to Dieter from comment #1)
> I tried to reproduce with the following steps
> 1. Open template
> 2. Insert some text and a footnote
> 3. Change character style of footnote anchor to "Footnote Anchor" and
> character style of footnote to "Footnote Characters"
> 4. Save as docx
> 5. Reload

Antonio wrote in private:
What do you mean with 

1)“Open template?” Do I open the file .ott or do I create a new document from the file .ott?

2) “Change character style of footnote anchor to "Footnote Anchor" and character style of footnote to "Footnote Characters"?
Comment 3 Dieter 2021-06-27 11:12:08 UTC
(In reply to Antonio from comment #2)
> What do you mean with 
> 1)“Open template?” Do I open the file .ott or do I create a new document
> from the file .ott?
Open  an .ott-file
 
> 2) “Change character style of footnote anchor to "Footnote Anchor" and
> character style of footnote to "Footnote Characters"?
Sorry, but don't understand that question.

Could you add a sample-document (ott-file before savng as docx?)?
=> NEEDINFO
Comment 4 QA Administrators 2021-12-25 03:44:14 UTC Comment hidden (obsolete)
Comment 5 Antonio 2021-12-27 08:56:41 UTC
Created attachment 177150 [details]
This is the template before saving as docx or doc. If I save as odt, no problem.
Comment 6 Antonio 2021-12-27 09:00:09 UTC
Can you explain in others words the meaning of ' “Change character style of footnote anchor to "Footnote Anchor" and > character style of footnote to "Footnote Characters" '?
Best regards to all.
Comment 7 Dieter 2022-01-03 12:14:34 UTC
I confrm it with

Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 9c95415de877af1430ab5b7123e11dedd0ea622c
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL


Steps to reproduce

1. Open attachment 177150 [details] as template
2. Save as docx. Close and reopen.
3. Compare character style "Footnote Anchor" in ott-file and docx-file

Actual result
Footnote Anchor: Character position is superscript 45% in ott and automatic (58%) in docx; character size is 70% in ott and 58% in docx

Expected result:
Should be the same.

Additional informations
I cant' see a difference in character stye "Footnote Character". Position and size is normal in both cases. So I changed bug summary. Please check again.

Antonio, I change status to NEW. If you assign a bug to yourself means, that you want to fix it. If this is your plan, please change status back to ASSIGNED.
Comment 8 Antonio 2022-01-04 12:55:57 UTC
I confirm, the bug persists. I wish it were fixed.
Comment 9 Dieter 2022-01-04 13:00:15 UTC
(In reply to Antonio from comment #8)
> I confirm, the bug persists. I wish it were fixed.

Please only change status to assigned, if you want to provide a fix for that bug. If you don't plan to fix it, please change status back to NEW.
Comment 10 Antonio 2022-01-04 13:11:32 UTC
I don't think I'll be able to fix the bug
Comment 11 Dieter 2022-01-04 14:27:25 UTC
(In reply to Antonio from comment #10)
> I don't think I'll be able to fix the bug

Antonio, please don't change version to 7.1.8.1 because Bugzilla asks for the earliest affected version and you've chosen 7.0.6.2 in your initial bug report.
Comment 12 Antonio 2022-01-08 18:20:00 UTC
I did the tests as required.
Endnote anchor.
Before the test, file ott.
1) Superscript
2) Rise / lower by: 45%
3) relative font size: 70%
After testing, file docx
4) Superscript
5) Rise / lower by: automatic
relative font size: 58%
Best regards.
Antonio
Comment 13 Justin L 2022-06-24 18:39:27 UTC
from bug 99602 comment 30:
DOCX: Please note that the character-style subscripts are set to automatic/default values intentionally, regardless of what the user entered for relative size/position. NOT doing that in direct formatting caused lots of these problems in the first place, and adding a style into the mix only complicates it that much more. It is better to let the computer be smart about subscripts, rather than to pretend that we can make print-perfect matching between two completely different ways of describing subscripts/superscripts.

Also see http://gerrit.libreoffice.org/c/core/+/80217/