Bug 142532 - Command Popup (HUD) search should return all items containing searched word regardless of its position
Summary: Command Popup (HUD) search should return all items containing searched word r...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.2.0.0 alpha1+
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.3.0 target:7.2.0
Keywords:
: 142949 (view as bug list)
Depends on:
Blocks: 91874
  Show dependency treegraph
 
Reported: 2021-05-28 05:25 UTC by stragu
Modified: 2021-08-12 22:36 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stragu 2021-05-28 05:25:11 UTC
Description:
Currently, the HUD only returns the items that have a name starting with the search term.

Steps to Reproduce:
1. Open Writer
2. Open the Command Popup (HUD) with the shortcut Ctrl + F1
3. Type "list"

Actual Results:
Only "List box" is returned.

Expected Results:
Other list items should be returned, including "Unordered list" and "Ordered list".


Reproducible: Always


User Profile Reset: No



Additional Info:
This is the case for any LO module that has the HUD: when searching, only the items that start with the search term show up, missing many relevant results. It results in a search experience that gives the user the impression that the HUD does not give access to many functions.

Tested in:

Version: 7.2.0.0.alpha1+ / LibreOffice Community
Build ID: a02d9e8de07de4ab9f586f82aed7a2e0413520cd
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-05-25_05:42:18
Calc: threaded
Comment 1 raal 2021-05-29 15:31:01 UTC
Reproducible with Version: 7.2.0.0.alpha1+ / LibreOffice Community
Build ID: 42d2b2d55a27f11153ea1713737d93540a19211d
CPU threads: 4; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded
Comment 2 stragu 2021-06-10 13:46:16 UTC
Not Linux-specific, confirmed on Windows 10 too:

Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: aa9cb8e14749e7fb7a83b55a2bb095501f731a18
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: en-AU (en_AU); UI: en-US
Calc: threaded
Comment 3 Tomaz Vajngerl 2021-08-04 07:19:21 UTC
*** Bug 142949 has been marked as a duplicate of this bug. ***
Comment 4 Commit Notification 2021-08-04 14:39:09 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/fc0d2136aee6c1749d780de09df025251703b59e

tdf#142532 search string at any position not just start

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Rizal Muttaqin 2021-08-07 09:55:49 UTC
Verified Fixed in:
Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 4e7212c4a341eef0521c4c6300c65bf42d756fd1
CPU threads: 4; OS: Linux 5.11; UI render: default; VCL: kf5 (cairo+xcb)
Locale: id-ID (id_ID.UTF-8); UI: id-ID
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-08-05_11:49:04
Calc: threaded
Comment 6 BogdanB 2021-08-07 17:59:33 UTC
Marked as verified based on comment 5.
A mention: the HUD is now accesible using Shift + Esc, not Ctrl + F1
Comment 7 Commit Notification 2021-08-07 21:24:10 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/9ff5dc848c3ffe6c2b259a8e6876b5b46ffb1b53

tdf#142532 search string at any position not just start

It will be available in 7.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 stragu 2021-08-08 05:53:03 UTC
Fabulous, thank you so much for the fix, Tomaž! This will be a very useful feature to many users.

Also verified on latest master build.
Comment 9 Commit Notification 2021-08-10 11:34:36 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "libreoffice-7-2-0":

https://git.libreoffice.org/core/commit/2f9880af7974b9297b48454070c26d2a4c3b63f0

tdf#142532 search string at any position not just start

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.