Download it now!
Bug 142618 - LibreOffice Viewer 7.2.0.0.alpha1+ crashes on "about" > "show notice"
Summary: LibreOffice Viewer 7.2.0.0.alpha1+ crashes on "about" > "show notice"
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Android Viewer (show other bugs)
Version:
(earliest affected)
7.2.0.0 alpha1+
Hardware: ARM Android
: medium normal
Assignee: Michael Weghorn
URL:
Whiteboard: target:7.3.0 target:7.2.0.0.beta2
Keywords:
Depends on:
Blocks:
 
Reported: 2021-06-02 12:00 UTC by g7nt9azamkb
Modified: 2021-06-17 07:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description g7nt9azamkb 2021-06-02 12:00:50 UTC
Description:
Dear team,

I've tested your LibreOffice Viewer Daily Build on Android and noticed several bugs:
- app crashes after clicking on 
  - about > show notice
  - about > show license
  - about > more info
- open an document fails
  Error: cannot open $Path*:loadComponentFromURL returned an emtpy reference.
  *Path differs every time I open a file.


Steps to Reproduce:
Regarding the crashes:
-Download current daily build apk
- Install and open it
- click on the menu options mentioned above
- crash

For the file opening bug
- Download and install current daily build
- install and open it
- Grand storage access
- open any document
- see failure

Actual Results:
APP crash bug > Crash
File open bug > Error message mentioned above

Expected Results:
APP crash bug: Show more information about the app
File open bug: Open File and show its data


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.0.0.alpha1+
Build ID: 75458bf
Comment 1 Julien Nabet 2021-06-02 12:38:47 UTC
Michael: noticing your work on Android part, thought you might be interested in this one.
Comment 2 Michael Weghorn 2021-06-11 12:03:49 UTC
Thanks for your bug report.

(In reply to g7nt9azamkb from comment #0)
> I've tested your LibreOffice Viewer Daily Build on Android and noticed
> several bugs:
> - app crashes after clicking on 
>   - about > show notice
>   - about > show license
>   - about > more info

There's a pending for for this in Gerrit:
https://gerrit.libreoffice.org/c/core/+/117053


> - open an document fails
>   Error: cannot open $Path*:loadComponentFromURL returned an emtpy reference.
>   *Path differs every time I open a file.

I cannot reproduce this with current daily build on a "real" device:

Version: 7.2.0.0.alpha1+
Build ID: 794eda0

arm64 device with Android 9

nor inside of an x86 AVD (Android Virtual Device) running Android R.

Opening documents works just fine for me.
However, there's another bug report, tdf#142426, that mentions the same issue.
Let's use tdf#142426 to further investigate this aspect. (It's best to use a separate bug report for each issue if they're unrelated.)

Are you possibly able to retrieve an ADB log for the case of opening "real" documents?

I'll close this bug report once https://gerrit.libreoffice.org/c/core/+/117053 has landed.
Comment 3 baffclan 2021-06-13 03:18:32 UTC
Reproduce with Newest build.

Build Info
tinderbox: administrator: lohmaier+tinderbox@gmail.com
tinderbox: buildname: Android-ARM@86-TDF
tinderbox: tree: MASTER
tinderbox: pull time 2021-06-12 07:36:10
tinderbox: git sha1s
core:0c8fa16c78e6887d6d3a6041166d388e266bbce7
Comment 4 Commit Notification 2021-06-13 18:50:05 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6bfa94398a0ea501fce7634ab0ae9ce35c442043

tdf#142618 android: Don't crash when passed MIME type is null

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Michael Weghorn 2021-06-13 18:52:31 UTC
Works OK for me with the commit from comment 4.
Do you get the "loadComponentFromURL returned an emtpy reference" issue (handled in tdf#142426) for the "About" > "Show notice" case as well now?
Comment 6 Commit Notification 2021-06-14 11:30:51 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/2fc22184a36572dd5d571fab29340ab517656436

tdf#142618 android: Don't crash when passed MIME type is null

It will be available in 7.2.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 g7nt9azamkb 2021-06-16 21:04:22 UTC
We the newest daily build

 Version: 7.3.0.0.alpha0+
Build ID: ba66d49

my problems have been fixed.

Device: Realme 7 Pro
Android: 10
Patch Level 2021-06-05
Comment 8 Michael Weghorn 2021-06-17 07:13:37 UTC
(In reply to g7nt9azamkb from comment #7)
> We the newest daily build
> 
>  Version: 7.3.0.0.alpha0+
> Build ID: ba66d49
> 
> my problems have been fixed.
> 
> Device: Realme 7 Pro
> Android: 10
> Patch Level 2021-06-05

Thanks for testing! Does that mean the "loadComponentFromURL returned an emtpy reference" issue is also gone?