Bug 142699 - EDITING Support change tracking of images anchored to character
Summary: EDITING Support change tracking of images anchored to character
Status: RESOLVED DUPLICATE of bug 141994
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Track-Changes-Image
  Show dependency treegraph
 
Reported: 2021-06-07 07:47 UTC by NISZ LibreOffice Team
Modified: 2021-06-23 10:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from Writer with enabled change tracking and images inserted (119.98 KB, application/vnd.oasis.opendocument.text)
2021-06-07 07:47 UTC, NISZ LibreOffice Team
Details
Screenshot of the problem in Writer (180.83 KB, image/png)
2021-06-07 07:48 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2021-06-07 07:47:59 UTC
Created attachment 172666 [details]
Example file from Writer with enabled change tracking and images inserted

Change tracking in Writer currently does not support the tracking of images anchored to character, only images anchored as character.
Inserting an image or drag-n-dropping from file manager creates images anchored as character, so it would be useful to track these changes.

Steps to reproduce:
    1. Open attached file, it has some text and change tracking is enabled.
    2. Insert – Image and insert one more image.
    3. From the file manager drag and drop an image into the document.

Actual results:
Inserting of images does not create a CT entry. The two images in the document wer e inserted with the above method, and the Manage Changes dialog does not display anything.

Expected results:
Change tracking records the insertion of images.

LibreOffice details:
Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 3b57ebb445df8a2bc3d916ea79f8af45e20e4e62
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 1 NISZ LibreOffice Team 2021-06-07 07:48:25 UTC
Created attachment 172667 [details]
Screenshot of the problem in Writer
Comment 2 NISZ LibreOffice Team 2021-06-07 07:56:38 UTC
bug #139228 might be about rejecting these kinds of changes. 
(although the example file there has a shape anchored to a deleted character, not image.)
Comment 3 Dieter 2021-06-22 06:44:10 UTC
(In reply to NISZ LibreOffice Team from comment #0)
> Change tracking in Writer currently does not support the tracking of images
> anchored to character, only images anchored as character.
> Inserting an image or drag-n-dropping from file manager creates images
> anchored as character, so it would be useful to track these changes.

Sorry, but I don't understand the problem. You say that only images anchored as character are treated as track changes and you say, that inserting an image or drag-n-drop it from file manager will anchor the image as character (I agree). So with both methods LO record these changes.

Tested with
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: de7356c2e0cb099fac396808b5a86a0393b48e5f
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Have I missed anything?
=> NEEDINFO
Comment 4 NISZ LibreOffice Team 2021-06-22 14:35:17 UTC
(In reply to Dieter from comment #3)
> (In reply to NISZ LibreOffice Team from comment #0)
> > Change tracking in Writer currently does not support the tracking of images
> > anchored to character, only images anchored as character.
> > Inserting an image or drag-n-dropping from file manager creates images
> > anchored as character, so it would be useful to track these changes.
> 
> Sorry, but I don't understand the problem. You say that only images anchored
> as character are treated as track changes and you say, that inserting an
> image or drag-n-drop it from file manager will anchor the image as character
> (I agree). So with both methods LO record these changes.

No, I said inserted images are anchored "To Character" and such images are not change tracked. 
Images anchored "As character" are.

This changed recently with: https://git.libreoffice.org/core/+/68b6004fe9df184bcbaf46dd53abfec228219df6
tdf#141994 track changes: record insertion of images

Now inserted images are anchored "As Character" if TC is enabled, so change tracking of inserted images now magically happens :).

Basically I forgot about already filing bug 141994.

*** This bug has been marked as a duplicate of bug 141994 ***