Bug 142717 - add toolbar menus for all kinds of styles (not just paragraph)
Summary: add toolbar menus for all kinds of styles (not just paragraph)
Status: RESOLVED DUPLICATE of bug 88512
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.2.2 release
Hardware: All Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-06-08 13:45 UTC by Ed Stauff
Modified: 2021-06-23 06:03 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Stauff 2021-06-08 13:45:53 UTC
Description:
One of the available widgets for toolbars is a drop-menu of paragraph styles.  I use this feature frequently.  I'd love to have similar widgets for the other kinds of styles, especially character styles.

Steps to Reproduce:
1. Open the Customize dialog.
2. In the Toolbars tab, type "style" in the Search box.
3. Add the command "Paragraph Style" to a toolbar and click "OK".
4. That command appears in the toolbar as a drop-down menu of available paragraph styles.
5. Repeat the previous steps, but try to find a command that will appear in the toolbar as a drop-down menu of available *character* styles.
 

Actual Results:
There is no command that will provide a drop-down menu of available character styles, or any other kind of style other than paragraph.
There are some commands whose names imply they might do that, but instead they do something different such as opening a dialog.

Expected Results:
For each kind of style (character, frame, list, page, paragraph, table), the Customize dialog should include a command that will add to the toolbar a drop-down menu of available styles of that type.  Selecting an item from one of these menus will apply the style to the selected text in the document.


Reproducible: Always


User Profile Reset: No



Additional Info:
What other information do you want?
Comment 1 Dieter 2021-06-23 06:03:15 UTC
Thank you for your bug report. We have bug 88512 with a request for character style drop-down and 107000 for list styles. So I think we can close it as duplicate.

*** This bug has been marked as a duplicate of bug 88512 ***