Bug 142902 - FILESAVE DOCX Remove personal information from change tracking and comments
Summary: FILESAVE DOCX Remove personal information from change tracking and comments
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL: https://support.microsoft.com/en-us/o...
Whiteboard: target:7.3.0 target:7.4.0 target:7.3.3
Keywords: filter:docx
Depends on:
Blocks: Options-Dialog DOCX-Track-Changes
  Show dependency treegraph
 
Reported: 2021-06-17 06:55 UTC by NISZ LibreOffice Team
Modified: 2022-03-11 12:24 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from Writer (13.80 KB, application/vnd.oasis.opendocument.text)
2021-06-17 06:55 UTC, NISZ LibreOffice Team
Details
The original file saved by Writer after enabling Remove personal info (7.85 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2021-06-17 06:56 UTC, NISZ LibreOffice Team
Details
Screenshot of the problem in Writer with the docx file (39.33 KB, image/png)
2021-06-17 06:56 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2021-06-17 06:55:20 UTC
Created attachment 172957 [details]
Example file from Writer

This is a followup to bug #90401
When the “Remove personal information on saving” security option is enabled and a change tracked, commented document is saved to DOCX format then the user data are retained: who made the changes/comments and when.

Steps to reproduce:
    1. Go to Tools – Options – Libreoffice - Security
    2. Press the Options button, in the dialog enable “Remove personal information on saving”
    3. In the Writer document enable Edit – Track changes – Record
    4. Make some addition, deletions, comments.
    5. Save as DOCX, reopen

Actual results:
Author name, change date are retained.

Expected results:
Author name and change date should be removed.
When opened in Word, there is a document level setting “Remove personal information from file properties on save” in the Trust Center – that option should also be enabled.

LibreOffice details:
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: b89ebf135818ccaa45bbfb164099a6e199bd7d11
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win
Locale: en-US (hu_HU); UI: en-US
Calc: CL
Comment 1 NISZ LibreOffice Team 2021-06-17 06:56:00 UTC
Created attachment 172958 [details]
The original file saved by Writer after enabling Remove personal info
Comment 2 NISZ LibreOffice Team 2021-06-17 06:56:18 UTC
Created attachment 172959 [details]
Screenshot of the problem in Writer with the docx file
Comment 3 Dieter 2021-07-02 07:44:18 UTC
I confirm it with

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 949658028e722e5d2657b503eb20e16e41dbd8cf
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Would treat it as a bug and not as enhancement request, because it works when saving as odt-file. Feel free to change it back to enhancement, if you disagree.
Comment 4 Commit Notification 2021-07-03 10:55:10 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ded2452a52d21131347a0dc2e25c8161f20fcfad

tdf#142902 DOCX export: remove personal info of comments and changes

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 BogdanB 2021-07-11 13:43:46 UTC
Tkanks for fixing this. Name and date was removed.

Verified in 
Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: eac5977bfc11797eda356560a5e45c51108ef5a1
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded

Just as a note, the name was replaced with "Author2" and the date is "(no date)". This was intentional?
Comment 6 Commit Notification 2022-03-10 18:14:40 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/64dcedcf7c073d1819794d68a33651b14877e1b5

tdf#147760 tdf#142902 DOCX export: anonymize date and moveFromRangeStart

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2022-03-11 12:24:34 UTC
László Németh committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/554d95b2b4ece9cd570dfbad357bfedafc6a4dd1

tdf#147760 tdf#142902 DOCX export: anonymize date and moveFromRangeStart

It will be available in 7.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.