Bug 143023 - Forms: Event "When losing focus" in tablecontrol appears when receiving focus
Summary: Forms: Event "When losing focus" in tablecontrol appears when receiving focus
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
7.1.4.2 release
Hardware: All All
: high major
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.3.0 target:7.2.1 target:7.1.6
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2021-06-23 17:30 UTC by Robert Großkopf
Modified: 2021-08-10 18:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Try switching through the tablecontrol: Event "losing focus" never happens. (14.17 KB, application/vnd.oasis.opendocument.database)
2021-06-23 17:30 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2021-06-23 17:30:25 UTC
Created attachment 173115 [details]
Try switching through the tablecontrol: Event "losing focus" never happens.

Open the attached database.
Open the form for input data.
Switch beginning with filed "Name" through the tablecontrol by tabulator.
Field "Name" isn't connected to a macro.
Field "E-Mail" is set to event "When losing focus". The message appears when receiving focus.
Field "Web" is set to event "When receiving focus". The message appears when receiving focus.

Seems "When losing focus" is connected to "When receivig focus" anywhere in the code. Event "When losing focus" doesn't happen.

Detected with LO 7.1.4.2 on OpenSUSE 15.2 64bit rpm Linux.
This bug doesn't appear with LO 7.0.5.2 on the same machine. But careful with the test here. Blocks all because "losing focus" will happen when the messagebox appears!
So this is a regression.
Comment 1 Alex Thurgood 2021-07-16 08:49:52 UTC
Confirming also with 

Version: 7.1.4.2 / LibreOffice Community
Build ID: a529a4fab45b75fefc5b6226684193eb000654f6
CPU threads: 8; OS: Mac OS X 10.16; UI render: default; VCL: osx
Locale: fr-FR (fr_FR.UTF-8); UI: fr-FR
Calc: threaded
Comment 2 Xisco Faulí 2021-07-20 15:00:05 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=d2f1cd004310b9ea6654d17fddc11cb08e884c90

author	Caolán McNamara <caolanm@redhat.com>	2020-06-26 20:57:29 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2020-07-01 18:04:46 +0200
commit	d2f1cd004310b9ea6654d17fddc11cb08e884c90 (patch)
tree	2d2ad2d4afa5e2eb1c62a8e7ee1ac7bd0bf4f791
parent	96dc14a041ea803f0d194a47a8f3d62f6cfa37be (diff)
weld EditControl for browsebox

Bisected with: bibisect-linux64-7.1

Adding Cc: to Caolán McNamara
Comment 3 Commit Notification 2021-08-04 14:51:27 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ee04805e513b0f804408697fc4b93e3c025d2329

Resolves: tdf#143023 explicitly connect to ControlBase focus-[in/out]

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Caolán McNamara 2021-08-05 15:50:41 UTC
provided case works now, backports to 7-2 and 7-1 in gerrit
Comment 5 Commit Notification 2021-08-10 17:54:12 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/e77d6b92c51a8adf517fd283cf8984345bc3f8ce

Resolves: tdf#143023 explicitly connect to ControlBase focus-[in/out]

It will be available in 7.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2021-08-10 18:26:57 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/d48afb9ae5d78d40ad826b4f1ed047b0fb93e1e4

Resolves: tdf#143023 explicitly connect to ControlBase focus-[in/out]

It will be available in 7.1.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.