Bug 143132 - FILEOPEN XLSX Second values are incorrectly not rounded
Summary: FILEOPEN XLSX Second values are incorrectly not rounded
Status: CLOSED DUPLICATE of bug 133919
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: XLSX
  Show dependency treegraph
 
Reported: 2021-06-30 12:37 UTC by NISZ LibreOffice Team
Modified: 2021-06-30 15:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of the attachment 170433 side by side in Excel and Calc (67.35 KB, image/png)
2021-06-30 12:37 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2021-06-30 12:37:35 UTC
Created attachment 173290 [details]
Screenshot of the attachment 170433 [details] side by side in Excel and Calc

When a time value of hours:minutes:seconds is stored in Excel and opened in Calc, there is a small rounding error: Excel stores hundredth seconds as well, but displays the value rounded to whole seconds.
Calc does not round these values but truncates them, as can be seen with attachment 170433 [details] of bug 140978.

Steps to reproduce:
    1. Open attachment 170433 [details]

Actual results:
Observe that the value in A6 is 8:17:40 in Excel but 8:17:39 in Calc.
This also causes the autofilter condition set to display the 8:17:40 value to not match the 8:17:39 value presented by Calc.

Expected results:
The value in A6 should be rounded to 8:17:40 in Calc as well.

LibreOffice details:
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 9c15dea0b2192d231b65175291a7655122c2e24c
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win
Locale: en-US (hu_HU); UI: en-US
Calc: CL

Also in 7.0, 6.2. 

Not yet in
Version: 6.1.0.3
Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: en-US (hu_HU); Calc: group threaded

Additional Information:
Bibisected using bibisect-win32-6.2 to:
URL: https://cgit.freedesktop.org/libreoffice/core/commit/?id=e2e47898180e547cad7ccde1e5890385d573e551 

author	Eike Rathke <erack@redhat.com>	2018-08-31 11:21:03 +0200
committer	Eike Rathke <erack@redhat.com>	2018-08-31 12:50:52 +0200

Use tools::Time::GetClock() in number formatter for wall clock time

Adding CC to: Eike Rathke
Comment 1 Eike Rathke 2021-06-30 13:12:31 UTC

*** This bug has been marked as a duplicate of bug 133919 ***