Bug 143140 - ODT: Bibliography index duplicated
Summary: ODT: Bibliography index duplicated
Status: RESOLVED DUPLICATE of bug 95285
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-06-30 18:11 UTC by Mihai Vasiliu
Modified: 2021-07-17 15:48 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Insert a new index in this document and observe index duplication (16.23 KB, application/vnd.oasis.opendocument.text)
2021-06-30 18:12 UTC, Mihai Vasiliu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mihai Vasiliu 2021-06-30 18:11:01 UTC
Description:
When inserting a new bibliography entry in the document, if the new entry is inserted between two existing entries, the index gets duplicated in both the reference and in the bibliography index

Steps to Reproduce:
1. Create a new LO Writer document
2. Insert some Lorem Ipsum paragraphs
3. Create a few new bibliography entries with the source being Document content and insert them into the document.
4. Create a Bibliography Index at the end. The index should be populated fine. Edit the index and change the entries to 'Number entries' instead of short name display.
5. Save the document as ODT, close and reopen.
6. Between any two existing bibliography references from the text, enther a new one. Let's say between [1] and [2], create and insert a new reference.
7. Observe that the new index is duplicated: now the indexes are [1], [2] and [2].
7. Update the bibliography index.
8. Notice that the bibliography index now contains duplicate entries: 1, 2, 2.

Actual Results:
The new bibliography index takes the same index as the next one, without renumbering them accordingly.

Expected Results:
A new index should be created and all the next indices should be renumbered: [1], [2], [3].
The Bibliography index should reflect this change and renumber the entries, without creating duplicates.


Reproducible: Always


User Profile Reset: No



Additional Info:
After saving and reopening the ODT document, sometimes the numbering is updated in the docuemnt, but the Bibliography index still shows duplicate numbers.
Comment 1 Mihai Vasiliu 2021-06-30 18:12:36 UTC
Created attachment 173297 [details]
Insert a new index in this document and observe index duplication

The index is duplicated and even if I select Update Index, the index does not get correct.
Comment 2 Buovjaga 2021-07-17 15:48:53 UTC
Repro with document. However, I found an older report

(In reply to Mihai Vasiliu from comment #0)
> 6. Between any two existing bibliography references from the text, enther a
> new one. Let's say between [1] and [2], create and insert a new reference.

Exact steps:

6a. Insert - Table of contents and index - Bibliography entry
6b. Click New in the dialog
6c. Input a unique short name and pick some random type

NixOS
Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: b1df9c67349cf4cc5be4128d797aefb87f50e38f
CPU threads: 16; OS: Linux 5.13; UI render: default; VCL: x11
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded

*** This bug has been marked as a duplicate of bug 95285 ***