Bug 143146 - Crash by click on properties symbol for calc data in writer
Summary: Crash by click on properties symbol for calc data in writer
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.3 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.3.0 target:7.2.0.0.beta2 tar...
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2021-07-01 10:08 UTC by Achim Wagenknecht
Modified: 2021-07-14 13:07 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Achim Wagenknecht 2021-07-01 10:08:04 UTC
Description:
Mark and copy table data in Calc
In Writer press Shift+Ctrl+V
Paste as calc table
Activate with double click
Click properties symbol in side bar
-> crash
7.1.4.2 Windows
LO fresh AppImage Linux (7.1.4.2): same crash
7.1.0.3 Windows: same crash
https://crashreport.libreoffice.org/stats/crash_details/ca5fd930-b35d-4a81-bc97-a5427e10c682

Steps to Reproduce:
1. Mark and copy table data in Calc
2. In Writer press Shift+Ctrl+V
3. Paste as calc table
4. Activate with double click
5. Click properties symbol in side bar

Actual Results:
crash

Expected Results:
properties open in side bar


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.4.2 / LibreOffice Community
Build ID: a529a4fab45b75fefc5b6226684193eb000654f6
CPU threads: 2; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: de-DE (de_DE.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2021-07-07 09:41:13 UTC
Reproduced in

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: eac5977bfc11797eda356560a5e45c51108ef5a1
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 2 Xisco Faulí 2021-07-07 10:18:40 UTC
Not reproducible in

Version: 7.0.0.0.alpha1+
Build ID: 574c57090642347980d2395e1e183cc7b5c171ad
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 3 raal 2021-07-07 21:37:57 UTC
This seems to have begun at the below commit.
Adding Cc: to Caolán McNamara ; Could you possibly take a look at this one?
Thanks

ef55d8fc00e064bd34ceefd7ec87ac6b336180c1 is the first bad commit
commit ef55d8fc00e064bd34ceefd7ec87ac6b336180c1
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Tue Nov 24 03:34:55 2020 +0100

    source sha:75b9109a2da35cf0f0914504145d84cf918c6af2

https://git.libreoffice.org/core/+/75b9109a2da35cf0f0914504145d84cf918c6af2
    weld TabBar
Comment 4 Caolán McNamara 2021-07-08 11:50:46 UTC
looks like during TabBar::Item::HandleClick the GrabFocusToDocument causes the TabBar::Item to be deleted so it crashes on the next line of the maDeckActivationFunctor(msDeckId) which seems to be there from https://bz.apache.org/ooo/show_bug.cgi?id=123198 which sounds like was a last-ditch effort to workaround the same underlying problem
Comment 5 Commit Notification 2021-07-08 18:18:08 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c109e1d1f5965fe03c666fee6c0bd4dd875f29c8

tdf#143146 copy functor and arg before calling function that can delete this

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Caolán McNamara 2021-07-08 18:20:03 UTC
backports to 7-2 and 7-1 in gerrit
Comment 7 Commit Notification 2021-07-09 07:59:07 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/95315e4a0cce767500e35fc32aa7aa25ca54c308

tdf#143146 copy functor and arg before calling function that can delete this

It will be available in 7.2.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2021-07-09 09:17:23 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/80f5f74b661b52717ec2848b98cad3be8192b330

tdf#143146 copy functor and arg before calling function that can delete this

It will be available in 7.1.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2021-07-12 08:03:31 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-1-5":

https://git.libreoffice.org/core/commit/5bbc018edd51634e659373b0815dde6f9e9184df

tdf#143146 copy functor and arg before calling function that can delete this

It will be available in 7.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 BogdanB 2021-07-14 13:07:04 UTC
No more crash in
Version: 7.2.0.1.0+ (x64) / LibreOffice Community
Build ID: ffeeb78118a887419c5f33bb5311f0e2ddae463c
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: ro-RO (ro_RO); UI: en-US
Calc: threaded

Tested in Version: 7.1.4.2 (x64) / LibreOffice Community
Build ID: a529a4fab45b75fefc5b6226684193eb000654f6
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: ro-RO (ro_RO); UI: en-US
Calc: threaded
and here is crashing, but will be solved in 7.1.5.