Bug 143214 - Large spreadsheets: Calc crashes (sometimes) when I change a value after a certain column ( steps in comment 10 )
Summary: Large spreadsheets: Calc crashes (sometimes) when I change a value after a ce...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.4.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 147912 (view as bug list)
Depends on:
Blocks: Calc-large-spreadsheets
  Show dependency treegraph
 
Reported: 2021-07-06 12:55 UTC by whiax
Modified: 2022-03-11 11:57 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test ODS (31.91 KB, application/vnd.oasis.opendocument.spreadsheet)
2021-09-06 10:14 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description whiax 2021-07-06 12:55:00 UTC
Description:
(1) I open a file with LibreOffice calc
(2) The file is displayed correctly
(3) I change one value and type "enter", Libreoffice crashes

It's important to know that I'm using the option to manipulate large sheets: "Enable very large spreadsheets". But I'm not at the limit of very large spreadsheets, I only have a bit more than 1040 columns. Also after it crashes, I can reload it and the modifications I made are present
The bug used to happen sometimes but now it's happening almost every time, but there's a part of randomness clearly.

crash report: https://crashreport.libreoffice.org/stats/crash_details/755ebc8a-2462-4caa-b7eb-c40fa76a4ce1#allthreads

Problems: EDITING

Steps to Reproduce:
1. Open a file with 1060 (+/-) columns
2. Modify the 1061th column
3. It crashes (randomly, sometimes it's 50% of the time and recently it's 90% of the time)

Actual Results:
Libreoffice displays a window to recover the document

Expected Results:
Not crashes


Reproducible: Sometimes


User Profile Reset: No



Additional Info:
I tried using the latest versions (7.1.5.1) to fix the issue but it didn't help
Comment 1 Timur 2021-07-06 14:24:43 UTC Comment hidden (obsolete)
Comment 2 whiax 2021-07-06 21:20:47 UTC
(In reply to Timur from comment #1)
> Please do all:
> 1. attach sample file with no personal info, just required 
> 2. test with Lo daily master 7.3+ from
> https://dev-builds.libreoffice.org/daily/master/current.html (separate to
> your working Lo) 
> 3. see other bugs in meta Bug 133764 (Calc-large-spreadsheets) if this is a
> duplicate


1. attach sample file with no personal info, just required 

The document contains personal info, I can't transmit it. I think I can reproduce it (but adding attachment doesn't work for now). 
Another way to reproduce? (1) create empty calc (2) add =1 in B2 and =B2+1 in C2 and continue until you're at 1087 in AOV (3) add a graph => crash (not 100% sure?) (4) relaunch (5) add a graph, it works (6) add stuff in next columns or latest columns, save, close, re-open etc. It's unstable.
Clearly it's hard to 100% reproduce the bug anyway. On the main file, I can modify stuff in the 1st columns (before the 200th column) but can't always do it in the last ones (after 1080).
I can confirm that this issue is still in 7.3 (daily/master/current).



2. test with Lo daily master 7.3+ from https://dev-builds.libreoffice.org/daily/master/current.html (separate to your working Lo) 

It crashes when I open the file, it says "Read Error.
An unknown error has occurred."
Comment 3 whiax 2021-07-06 21:20:47 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2021-07-07 04:04:27 UTC Comment hidden (obsolete)
Comment 5 raal 2021-07-07 06:54:27 UTC Comment hidden (obsolete)
Comment 6 Xisco Faulí 2021-07-07 09:35:07 UTC Comment hidden (obsolete)
Comment 7 whiax 2021-07-07 19:37:00 UTC
(In reply to Xisco Faulí from comment #6)
> hello whiax,
> Would you mind sending me the document privately to my email ? This way I
> can investigate this issue. I won't share it with anybody else. Thanks in
> advance

Hi,

I managed to reproduce a bug that I guess is the same on a completely new document with latest lo version.

Video on how to reproduce: https://www.youtube.com/watch?v=2Usq0Fw2Axs (steps are in my previous message)

I'm not 100% sure that it's the same bug but it seems very related. I just removed all graphs from my original "confidential" file and it seems to be working much better after I copied all values (ctrl+c / ctrl+v) in a new ODS document.
I'm quite confident that it's not going to crash this way but I'll update if it does.
Comment 8 QA Administrators 2021-07-08 03:44:10 UTC Comment hidden (obsolete)
Comment 9 Timur 2021-07-15 12:12:29 UTC
Video not available. We still need example file, please make one per comment 2. 
Let's check if a duplicate of Bug 141769 that's fixed in 7.1.5.1, please try from Libreoffice.org Downloads Pre-release section or wait final 7.1.5.2.
Comment 10 Timur 2021-09-06 10:14:57 UTC
Created attachment 174810 [details]
Test ODS

I confirm the bug with LO 7.3+ in Windows.
In test ODS try to change AOV2 (I added +10).
Comment 11 Timur 2021-09-06 13:27:22 UTC
Test file cannot be open with LO 7.0 and 7.1. 
Opening it in 7.3+ I don't reproduce the bug again, so repro steps are still needed.
Comment 12 Xisco Faulí 2021-09-14 14:17:52 UTC
(In reply to Timur from comment #10)
> Created attachment 174810 [details]
> Test ODS
> 
> I confirm the bug with LO 7.3+ in Windows.
> In test ODS try to change AOV2 (I added +10).

Also reproducible in

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: e7a40c0ded1ba26b6b8f3da5a0b894e9c7ee7a96
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: x11
Locale: de-DE (en_US.UTF-8); UI: en-US
Calc: threaded Jumbo

with jumbo spreadsheets enabled
Comment 13 Luboš Luňák 2022-02-14 11:58:41 UTC
I cannot reproduce with current master.
Comment 14 Roman Kuznetsov 2022-02-15 08:32:12 UTC
(In reply to Luboš Luňák from comment #13)
> I cannot reproduce with current master.

no problem in

Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 0bf0feb40ae5c394a14cdfe4f94fb98dd9053597
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: CL Jumbo

whiax, could you retest your problem in current dev build?

https://dev-builds.libreoffice.org/daily/master/current.html
Comment 15 Timur 2022-03-04 12:43:46 UTC
I have different crashes with 7.3.0. Seems that 7.4+ is OK. WFM.
Comment 16 Xisco Faulí 2022-03-11 11:57:39 UTC
*** Bug 147912 has been marked as a duplicate of this bug. ***