Bug 143266 - [ToD] error in menu entry
Summary: [ToD] error in menu entry
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.3.0.0 alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.4.0
Keywords: difficultyBeginner, easyHack, skillDesign, topicDesign
Depends on:
Blocks: Tip-Of-The-Day
  Show dependency treegraph
 
Reported: 2021-07-08 15:38 UTC by sophie
Modified: 2022-02-14 10:07 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Julien Nabet 2021-07-09 09:14:01 UTC
Heiko: thought you might be interested in this one.
Comment 2 sophie 2021-07-09 13:15:19 UTC
Adding this one here too as it's also a change in menu.
location of the string:
https://git.libreoffice.org/core/+/master/cui/inc/tipoftheday.hrc#149

weblate comment:
The name of the menu item seems to be "Table of Contents and Index", not just "Table of Contents".
Also, the context menu item seems to be "Edit index", so a better phrasing for the part in parentheses would be "(or right-click and select Edit index to edit a previously inserted index)".
Comment 3 Heiko Tietze 2021-07-12 12:18:23 UTC
Easy hackable... IMO not worth the effort as ToC is pretty much clear without "index" and the same for "Autoformat Styles". Sure, could be different with the translation and no objection from my side.
Comment 4 Commit Notification 2022-02-14 10:06:59 UTC
Roman Kuznetsov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/23f1d0436f4a23b496c271c86325b8e336d60f3b

tdf#143266 Use correct menu item's names in ToD

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.