Bug 143300 - Add icons for diagonal borders
Summary: Add icons for diagonal borders
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.3.0.0 alpha0+
Hardware: All All
: medium enhancement
Assignee: Rizal Muttaqin
URL:
Whiteboard: target:7.3.0
Keywords:
Depends on:
Blocks: 51665
  Show dependency treegraph
 
Reported: 2021-07-11 12:27 UTC by Bayram Çiçek
Modified: 2021-12-29 06:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
border icons in MS office (left) and LibreOffice (right) (121.83 KB, image/png)
2021-07-11 12:34 UTC, Bayram Çiçek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bayram Çiçek 2021-07-11 12:27:59 UTC
Description:
In Writer, there are 12 icons available for table borders. The icons file names exist from  "fr01.*" to "fr012.*".

Writer needs 2 new icons for diagonal left and diagonal right borders. These icons are needed for https://bugs.documentfoundation.org/show_bug.cgi?id=51665 .

It will be good if:
"fr013.*" -> for diagonal left border
"fr014.*" -> for diagonal right border. 

Steps to Reproduce:
-

Actual Results:
-

Expected Results:
-


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 8b7f948d9d79393bc6c1b11d239706666fd5d7de
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Bayram Çiçek 2021-07-11 12:34:16 UTC
Created attachment 173492 [details]
border icons in MS office (left) and LibreOffice (right)
Comment 2 Telesto 2021-07-11 12:50:54 UTC
@Heiko
For keeping tabs..
Comment 3 Heiko Tietze 2021-07-12 07:48:38 UTC
Yes, Rizal offered his service and asked for this ticket on Telegram.
Comment 4 Telesto 2021-07-12 09:26:50 UTC
(In reply to Heiko Tietze from comment #3)
> Yes, Rizal offered his service and asked for this ticket on Telegram.

Intended for mentioning: The Table -> Properties -> Border dialog has to be adapted to support diagonal borders too (bug 51665). Aside from changes in functioning (my major off-topic concern) it might need icons too?
Comment 5 Rizal Muttaqin 2021-07-13 08:51:30 UTC
https://gerrit.libreoffice.org/c/core/+/118821
Comment 6 Commit Notification 2021-07-14 02:25:55 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/08f7cdb51775dc0988d4bb9cd1d0b8f9487861aa

tdf#143300 add diagonal border for Writer table

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Heiko Tietze 2021-07-14 05:26:02 UTC
(In reply to Commit Notification from comment #6)
> Rizal Muttaqin committed a patch related to this issue.

Guess it's solved with the patch.
Comment 8 Commit Notification 2021-07-14 05:54:26 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/cfb25346ffe0ec8a65b4db2630ea615077fba277

Breeze: tdf#143300 add diagonal border line icons

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Rizal Muttaqin 2021-07-14 05:59:38 UTC
(In reply to Telesto from comment #4)
> (In reply to Heiko Tietze from comment #3)
> > Yes, Rizal offered his service and asked for this ticket on Telegram.
> 
> Intended for mentioning: The Table -> Properties -> Border dialog has to be
> adapted to support diagonal borders too (bug 51665). Aside from changes in
> functioning (my major off-topic concern) it might need icons too?

I guess my patch just affect the border in Table toolbar. Your concern seems valid, we need diagonal variant also for Table Properties

(In reply to Heiko Tietze from comment #7)
> Guess it's solved with the patch.

No, beside above reason, I have to make sure also that all themes already support this request
Comment 10 Commit Notification 2021-07-22 18:34:15 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/80a1c6ea4771cd9620addde2640d3c4d6276a5de

elementary tdf#143300 add diagonal border line icons

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Madison Wilson 2021-07-28 05:30:54 UTC Comment hidden (spam)
Comment 12 saskatoonsolar 2021-08-09 02:28:46 UTC Comment hidden (spam)
Comment 13 Bayram Çiçek 2021-08-17 20:44:06 UTC
@Rizal Muttaqin:

we can add "fr015.*" -> for criss-cross border.

as @Heiko Tietze suggested here: https://gerrit.libreoffice.org/c/core/+/118951 , I implemented criss-cross border UI with the last patchset.

since criss-cross border doesn't exist in icons start with "fr*", I used "svx/res/pr06.png" for now. (but it doesn't fit very well in the box. when the criss-cross border becomes available, then I'll submit a new commit for the correct icon asap)

What do you think?
Thanks.
Comment 14 Rizal Muttaqin 2021-08-24 00:28:07 UTC
(In reply to Bayram Çiçek from comment #13)
> @Rizal Muttaqin:
> 
> we can add "fr015.*" -> for criss-cross border.
> 
> as @Heiko Tietze suggested here:
> https://gerrit.libreoffice.org/c/core/+/118951 , I implemented criss-cross
> border UI with the last patchset.
> 
> since criss-cross border doesn't exist in icons start with "fr*", I used
> "svx/res/pr06.png" for now. (but it doesn't fit very well in the box. when
> the criss-cross border becomes available, then I'll submit a new commit for
> the correct icon asap)
> 
> What do you think?
> Thanks.

https://gerrit.libreoffice.org/c/core/+/120862

Here the patch for Colibre.
Comment 15 Commit Notification 2021-08-24 02:03:19 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ddf2e96b83fc28ba6ae3f204f6eba7972c7d2f13

Colibre: tdf#143300 add criss-cross border

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2021-08-24 02:23:38 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/83f5c19ae01c29bd95f605c0cf8ceb00cd1fb222

Breeze: tdf#143300 add criss-cross border

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2021-08-24 02:39:54 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3ee22d95d3e1e9ce1d2ff8311e51d600179370f9

elementary: tdf#143300 add criss-cross border

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2021-08-24 05:44:20 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d5d97d251f779fd78490ab7723a134dda1a11960

Sukapura: tdf#143300 add diagonal border

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2021-08-24 05:45:31 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1044496d10f2dc5097324dd8857bc6969ac013dc

Karasa Jaga: tdf#143300 add diagonal border

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2021-08-26 09:28:39 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/282b2d8bfd6fb16f58fb177910427b031dc80066

Sifr: tdf#143300 add diagonal border

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Mehmet gelisin 2021-09-11 13:04:18 UTC Comment hidden (spam)
Comment 22 namboru 2021-09-17 06:39:23 UTC Comment hidden (spam)
Comment 23 Zeinab 2021-09-29 06:15:56 UTC Comment hidden (spam)
Comment 24 flooringelgin 2021-10-01 14:47:27 UTC Comment hidden (spam)
Comment 25 flooringelgin 2021-10-01 14:54:22 UTC Comment hidden (spam)
Comment 26 stragu 2021-12-29 03:16:45 UTC
Verified fixed in:

Version: 7.3.0.1 / LibreOffice Community
Build ID: 840fe2f57ae5ad80d62bfa6e25550cb10ddabd1d
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

However, the buttons still have no effect, which I assume is what is tracked in bug 51665

Adding buttons to add diagonal borders, but not having diagonal borders implemented, does bump up the priority of bug 51665 in my opinion.
I see that it is currently set to a "high" priority enhancement, which seems fair.
Comment 27 Bayram Çiçek 2021-12-29 06:52:36 UTC
please see the comments at Bug 146407.
(the suggestion is to hide diagonal border icons for Writer - until the feature is implemented.)