Bug 143320 - Crash at paste/undo paste again (swlo!BigPtrArray::Index2Block+0xc8)
Summary: Crash at paste/undo paste again (swlo!BigPtrArray::Index2Block+0xc8)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.3.0.0 alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.3.0 target:7.2.0.2
Keywords: bibisected, bisected, regression, wantBacktrace
: 143322 (view as bug list)
Depends on:
Blocks: Crash-BigPtrArray
  Show dependency treegraph
 
Reported: 2021-07-12 17:44 UTC by Telesto
Modified: 2021-07-15 13:20 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2021-07-12 17:44:53 UTC
Description:
Crash at paste/undo paste again (swlo!BigPtrArray::Index2Block+0xc8)

Steps to Reproduce:
1. Open attachment 173501 [details] (bug 143310)
2. CTRL+A
3. CTRL+C
4. CTRL+N
5. CTRL+V
6. CTRL+Z
7. CTRL+V

Actual Results:
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 0fc020fb73c86a20608e8dff12af607e60327379
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2021-07-12 17:47:15 UTC
Not in
Version: 7.1.0.0.beta1+ (x64)
Build ID: f9fab4203c1aa0b9a3f27ce2713b6d5addc7df19
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: nl-NL
Calc: CL
Comment 2 Telesto 2021-07-12 18:05:53 UTC
Similar report, bit with different stack: bug 143322
Could be same thing, could be different
Comment 3 m.a.riosv 2021-07-12 19:52:38 UTC
Repro,
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 0fc020fb73c86a20608e8dff12af607e60327379
CPU threads: 4; OS: Windows 10.0 Build 21390; UI render: Skia/Vulkan; VCL: win
Locale: es-ES (es_ES); UI: en-US Calc: threaded
Comment 4 Xisco Faulí 2021-07-13 09:23:32 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=790135003b03b38a14efb7e0d345188607020a99

author	Noel Grandin <noel.grandin@collabora.co.uk>	2021-05-19 20:03:07 +0200
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2021-05-19 20:47:22 +0200
commit	790135003b03b38a14efb7e0d345188607020a99 (patch)
tree	bebd5d423e5753095d7cae97a717604e18b47124
parent	f8c1048eb437b1e685b76198165844e2ecc97a56 (diff)
fix leak when removing PageDesc

Bisected with: bibisect-linux64-7.2

Adding Cc: to Noel Grandin
Comment 5 Commit Notification 2021-07-14 10:12:17 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2575f9757126228ba43f382a419b92e71ee5b608

tdf#143320 Crash at paste/undo paste again

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2021-07-14 15:32:16 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/ac1817a2fb9fde32f40c5afe96bab174621de892

tdf#143320 Crash at paste/undo paste again

It will be available in 7.2.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Telesto 2021-07-15 10:06:06 UTC
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 717dc8e3575a18e1e18dc446031e6db4e60a873d
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: en-US (nl_NL); UI: en-US
Calc: CL
Comment 8 Telesto 2021-07-15 10:07:52 UTC
*** Bug 143322 has been marked as a duplicate of this bug. ***