Bug 143355 - crash with .uno:FontWork
Summary: crash with .uno:FontWork
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
7.3.0.0 alpha0+ Master
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: target:7.3.0 target:7.2.0.2
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2021-07-14 12:16 UTC by Regina Henschel
Modified: 2021-07-17 18:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
MS VS call stack (4.45 KB, text/plain)
2021-07-14 12:16 UTC, Regina Henschel
Details
Content of "Autos" window in VS at moment of crash (2.16 KB, text/plain)
2021-07-14 12:18 UTC, Regina Henschel
Details
bt with debug symbols (9.16 KB, text/plain)
2021-07-14 18:49 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2021-07-14 12:16:59 UTC
Created attachment 173558 [details]
MS VS call stack

Start Draw.
Customize a toolbar to contain the command .uno:FontWork. That command is contained in Category "Format".

Create a curve. Add some text to it. Click on icon 'FontWork' => Crash.

I see the crash in my debug build Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 3aa1152ccee13869b2c1d64a296524cf4fb73fa8
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: de-DE (en_US); UI: en-US
Calc: threaded

I have not tested a daily build.

It crashes after SAL_WARN_IF with info
warn:vcl.layout:5240:7512:D:\Build_2020\core\include\vcl/builder.hxx:437: .ui widget "DockingFontwork" needs to correspond to vcl type class VclBox.
Comment 1 Regina Henschel 2021-07-14 12:18:04 UTC
Created attachment 173559 [details]
Content of "Autos" window in VS at moment of crash
Comment 2 Julien Nabet 2021-07-14 18:49:31 UTC
Created attachment 173585 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I could reproduce the crash with gen rendering.

With gtk3 rendering, I don't reproduce the crash but noticed this:
(soffice:33916): GLib-GObject-WARNING **: 20:40:33.018: invalid cast from 'GtkGrid' to 'GtkBox'
Comment 3 Julien Nabet 2021-07-14 19:17:52 UTC
I gave a try with https://gerrit.libreoffice.org/c/core/+/118953

It fixes the crash but dialog box is not right since it expands too much horizontally.
Comment 4 Commit Notification 2021-07-15 13:07:55 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/48b6f94fa2fb533b9c5becb348a1433fc6b4175b

tdf#143355: fix crash with .uno:FontWork

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Julien Nabet 2021-07-15 17:45:50 UTC
Thank you Caolán for your help on ui part!
I confirm it doesn't crash and visually, it's ok now with gen and gtk3 renderings.
Comment 6 Commit Notification 2021-07-17 18:52:35 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/591d49a1711d5e23b3237c96517a9ec2dafee660

tdf#143355: fix crash with .uno:FontWork

It will be available in 7.2.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.