Bug 143417 - Shift + Click doesn't work to select image object
Summary: Shift + Click doesn't work to select image object
Status: RESOLVED DUPLICATE of bug 122179
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Selection
  Show dependency treegraph
 
Reported: 2021-07-17 05:56 UTC by xdnroot
Modified: 2021-07-18 06:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description xdnroot 2021-07-17 05:56:19 UTC
Description:
I can't select multiple image object with Shift + Click. I tried another key combination such as CTRL + Click and Alt + Click, but those doesn't work.

I think, it happen when one of the object is image. Because selection works when the object is text box and shape.

Steps to Reproduce:
1. Add multiple images (at least two images) to the workspace.
2. Select the first image, by click it.
3. Add the second image to selection area by Shift + Click the second image.


Actual Results:
Both image NOT selected and the cursor move to text prompt.

Expected Results:
 Both image selected.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes


Version: 7.1.4.2 / LibreOffice Community
Build ID: 10(Build:2)
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Ubuntu package version: 1:7.1.4~rc2-0ubuntu0.20.04.1~lo1
Calc: threaded
Comment 1 Buovjaga 2021-07-17 13:43:33 UTC
Reproduced. Selecting multiple shapes seems to work fine. I searched for dupes, but suprisingly could find none.

NixOS
Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: b1df9c67349cf4cc5be4128d797aefb87f50e38f
CPU threads: 16; OS: Linux 5.13; UI render: default; VCL: x11
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded

Version: 7.1.4.2 / LibreOffice Community
Build ID: 10(Build:2)
CPU threads: 16; OS: Linux 5.13; UI render: default; VCL: gtk3
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Comment 2 V Stuart Foote 2021-07-18 03:59:05 UTC
Seems a dupe of bug 122179 which is NAB; images on Writer canvas (SVM or BMP) held in Frames are simply not multi-selectable...
Comment 3 Buovjaga 2021-07-18 06:30:06 UTC
Oups...

*** This bug has been marked as a duplicate of bug 122179 ***