Bug 143699 - Data -> Validity [Cell range] doesn't save "Sort entries" in xlsx format
Summary: Data -> Validity [Cell range] doesn't save "Sort entries" in xlsx format
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Cell-Validity
  Show dependency treegraph
 
Reported: 2021-08-03 07:56 UTC by PremPa
Modified: 2021-08-05 16:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Reproducer document per instructions (11.63 KB, application/vnd.oasis.opendocument.spreadsheet)
2021-08-03 12:04 UTC, NISZ LibreOffice Team
Details
The reproducer document and its xlsx version opened in Excel (115.07 KB, image/png)
2021-08-03 12:07 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description PremPa 2021-08-03 07:56:08 UTC
Description:
If you flag Sort entries in cell range and save in xlsx the option is not flagged when you open again the xlsx file.
If you make the same and save in ods it works perfectly.

Steps to Reproduce:
1.
In column A, make a list with a few duplicates
2.
Create a dropdown for the column A and flag Sort entries
3.
Save as .xlsx and close the file
4.
Reopen the file and check the dropdown

Actual Results:
The dropdown shows all the duplicates values 

Expected Results:
The dropdown should be filed by unique values


Reproducible: Always


User Profile Reset: No



Additional Info:
If you save the file in .ods all works as expected
Comment 1 Nina_Shtygailo 2021-08-03 10:17:52 UTC
I can't to reproduce the error because the reproduction steps are not detailed enough. For example, how do I create a dropdown list?
Comment 2 PremPa 2021-08-03 10:29:00 UTC
(In reply to Nina_Shtygailo from comment #1)
> I can't to reproduce the error because the reproduction steps are not
> detailed enough. For example, how do I create a dropdown list?

To create the dropdown:

Go in an empty cell B2 
Data -> Validity -> Criteria -> Cell range
Deselect Allow blank cells
Flag Sort entries ascending
Source A:A
OK
Comment 3 Nina_Shtygailo 2021-08-03 11:33:14 UTC
no repro in

Version: 7.1.5.2 (x64) / LibreOffice Community
Build ID: 85f04e9f809797b8199d13c421bd8a2b025d52b5
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: en-US (ru_RU); UI: en-US
Calc: CL
Comment 4 NISZ LibreOffice Team 2021-08-03 12:04:54 UTC
Created attachment 174041 [details]
Reproducer document per instructions
Comment 5 NISZ LibreOffice Team 2021-08-03 12:07:24 UTC
Created attachment 174042 [details]
The reproducer document and its xlsx version opened in Excel

Looks like this is a Calc-only setting. My Excel 19 does not have an equivalent option in the dialog. So XLSX save loses the setting.

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 7c38362dbe1922c9825dffb463072030948d406b
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: en-US (hu_HU); UI: en-US
Calc: CL
Comment 6 PremPa 2021-08-04 14:31:41 UTC
(In reply to NISZ LibreOffice Team from comment #5)
> Looks like this is a Calc-only setting. My Excel 19 does not have an
> equivalent option in the dialog. So XLSX save loses the setting.

Yes, I see it now.

On the other hand, it seems to me that Excel always creates lists without duplicates.

Obviously that's my limit, but I don't understand the need to list all data in a range including duplicates.

This is why I don't understand the need for that flag.
Comment 7 m.a.riosv 2021-08-05 16:23:12 UTC
Then you are asking for a different thing, not duplicates even not sorted.
Please open a new bug - enhancement for that.