Bug 143703 - --convert-to epub triggers sw/source/core/undo/unattr.cxx:105: SwUndoFormatAttr::SwUndoFormatAttr(const SfxItemSet &, SwFormat &, bool): Assertion `m_sFormatName.getLength()' failed
Summary: --convert-to epub triggers sw/source/core/undo/unattr.cxx:105: SwUndoFormatAt...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Michael Stahl (allotropia)
URL:
Whiteboard: target:7.5.0 target:7.4.1 target:7.3.6
Keywords:
Depends on:
Blocks: Crash-Assert
  Show dependency treegraph
 
Reported: 2021-08-03 12:36 UTC by Stephan Bergmann
Modified: 2022-08-04 23:27 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stephan Bergmann 2021-08-03 12:36:12 UTC
At least with my local --enable-dbgutil Linux build of recent master towards LO 7.3, with cloudon/File_24.docx from the crash-testing corpus:

> $ instdir/program/soffice --headless --convert-to epub cloudon/File_24.docx
[...]
> soffice.bin: ~/lo/core/sw/source/core/undo/unattr.cxx:105: SwUndoFormatAttr::SwUndoFormatAttr(const SfxItemSet &, SwFormat &, bool): Assertion `m_sFormatName.getLength()' failed.
> Unspecified Application Error
> 
> 
> Fatal exception: Signal 6
> Stack:
> ~/lo/core/instdir/program/soffice.bin(backtrace+0x5b)[0x28a57b]
> ~/lo/core/instdir/program/libuno_sal.so.3(+0x56f45b)[0x7f157eba445b]
> ~/lo/core/instdir/program/libuno_sal.so.3(+0x56ec2e)[0x7f157eba3c2e]
> ~/lo/core/instdir/program/libuno_sal.so.3(+0x56c7eb)[0x7f157eba17eb]
> /lib64/libpthread.so.0(+0x13a20)[0x7f157d1bba20]
> /lib64/libc.so.6(gsignal+0x142)[0x7f157cfe62a2]
> /lib64/libc.so.6(abort+0x116)[0x7f157cfcf8a4]
> ~/lo/core/instdir/program/libvcllo.so(+0xab4a0d2)[0x7f154a8a00d2]
> ~/lo/core/instdir/program/libvcllo.so(_ZN11Application5AbortERKN3rtl8OUStringE+0x82)[0x7f1549b438a2]
> ~/lo/core/instdir/program/libsofficeapp.so(+0x7ef877)[0x7f157dd26877]
> ~/lo/core/instdir/program/libvcllo.so(+0x9e9a82c)[0x7f1549bf082c]
> ~/lo/core/instdir/program/libuno_sal.so.3(+0x2f68d2)[0x7f157e92b8d2]
> ~/lo/core/instdir/program/libuno_sal.so.3(+0x56c798)[0x7f157eba1798]
> /lib64/libpthread.so.0(+0x13a20)[0x7f157d1bba20]
> /lib64/libc.so.6(gsignal+0x142)[0x7f157cfe62a2]
> /lib64/libc.so.6(abort+0x116)[0x7f157cfcf8a4]
> /lib64/libc.so.6(+0x26789)[0x7f157cfcf789]
> /lib64/libc.so.6(+0x35a16)[0x7f157cfdea16]
> ~/lo/core/instdir/program/../program/libswlo.so(+0xf80c522)[0x7f14eea36522]
> ~/lo/core/instdir/program/../program/libswlo.so(+0xf80b311)[0x7f14eea35311]
> ~/lo/core/instdir/program/../program/libswlo.so(_ZNK8SwModify18CallSwClientNotifyERK7SfxHint+0x410)[0x7f14ea6b4be0]
> ~/lo/core/instdir/program/../program/libswlo.so(_ZNK2sw18BroadcastingModify18CallSwClientNotifyERK7SfxHint+0x136)[0x7f14ea6b4ed6]
> ~/lo/core/instdir/program/../program/libswlo.so(_ZN8SwModify14SwClientNotifyERKS_RK7SfxHint+0x360)[0x7f14ea6b26e0]
> ~/lo/core/instdir/program/../program/libswlo.so(_ZN8SwFormat14SwClientNotifyERK8SwModifyRK7SfxHint+0x416b)[0x7f14ea6f922b]
> ~/lo/core/instdir/program/../program/libswlo.so(_ZN13SwFrameFormat14SwClientNotifyERK8SwModifyRK7SfxHint+0x47e6)[0x7f14ecf699f6]
> ~/lo/core/instdir/program/../program/libswlo.so(+0xb48b404)[0x7f14ea6b5404]
> ~/lo/core/instdir/program/../program/libswlo.so(_ZN8SwFormat13SetFormatAttrERK10SfxItemSet+0x3621)[0x7f14ea703d51]
> ~/lo/core/instdir/program/../program/libswlo.so(_ZN5SwDoc7SetAttrERK10SfxItemSetR8SwFormat+0x4dd)[0x7f14eb29281d]
> ~/lo/core/instdir/program/../program/libswlo.so(_ZN5SwDoc7SetAttrERK11SfxPoolItemR8SwFormat+0x454)[0x7f14eb2921f4]
> ~/lo/core/instdir/program/../program/libswlo.so(_ZN10SwFlyFrame7ChgSizeERK4Size+0x1369)[0x7f14ed154149]
> ~/lo/core/instdir/program/../program/libswlo.so(_ZN9SwFEShell19RequestObjectResizeERK6SwRectRKN3com3sun4star3uno9ReferenceINS5_5embed15XEmbeddedObjectEEE+0x3e5d)[0x7f14eccc5f4d]
> ~/lo/core/instdir/program/../program/libswlo.so(+0x12836408)[0x7f14f1a60408]
> ~/lo/core/instdir/program/libsfxlo.so(+0x5793672)[0x7f156b42b672]
> ~/lo/core/instdir/program/../program/libembobj.so(+0x27f69e)[0x7f126fc7c69e]
> ~/lo/core/instdir/program/../program/libembobj.so(+0x35ff7e)[0x7f126fd5cf7e]
> ~/lo/core/instdir/program/../program/libchartcorelo.so(_ZN5chart10ChartModel28impl_notifyModifiedListenersEv+0x919)[0x7f126e1cf5d9]
> ~/lo/core/instdir/program/../program/libchartcorelo.so(_ZN5chart10ChartModel11setModifiedEh+0x8b6)[0x7f126e1c5d16]
> ~/lo/core/instdir/program/../program/libchartcorelo.so(_ZN5chart10ChartModel8modifiedERKN3com3sun4star4lang11EventObjectE+0xf05)[0x7f126e1d1205]
> ~/lo/core/instdir/program/../program/libchartcorelo.so(+0x332c8ef)[0x7f126ea988ef]
> ~/lo/core/instdir/program/../program/libchartcorelo.so(+0x31567c6)[0x7f126e8c27c6]
> ~/lo/core/instdir/program/../program/libchartcorelo.so(+0x3156174)[0x7f126e8c2174]
> ~/lo/core/instdir/program/../program/libchartcorelo.so(+0x332c8ef)[0x7f126ea988ef]
> ~/lo/core/instdir/program/../program/libchartcorelo.so(+0x31567c6)[0x7f126e8c27c6]
> ~/lo/core/instdir/program/../program/libchartcorelo.so(+0x3156174)[0x7f126e8c2174]
> ~/lo/core/instdir/program/../program/libchartcorelo.so(+0x332c8ef)[0x7f126ea988ef]
> ~/lo/core/instdir/program/../program/libchartcorelo.so(+0x31567c6)[0x7f126e8c27c6]
> ~/lo/core/instdir/program/../program/libchartcorelo.so(+0x3156174)[0x7f126e8c2174]
> ~/lo/core/instdir/program/../program/libchartcorelo.so(+0x291bb6a)[0x7f126e087b6a]
> ~/lo/core/instdir/program/../program/libchartcorelo.so(+0x291ee11)[0x7f126e08ae11]
> ~/lo/core/instdir/program/../program/libchartcorelo.so(+0x31e3eb1)[0x7f126e94feb1]
> ~/lo/core/instdir/program/libuno_cppuhelpergcc3.so.3(_ZN4cppu18OPropertySetHelper16setPropertyValueERKN3rtl8OUStringERKN3com3sun4star3uno3AnyE+0x3e4)[0x7f1576990b24]
> ~/lo/core/instdir/program/../program/libchartcorelo.so(_ZNK5chart15WrappedProperty16setPropertyValueERKN3com3sun4star3uno3AnyERKNS4_9ReferenceINS3_5beans12XPropertySetEEE+0x595)[0x7f126eaa9c65]
> ~/lo/core/instdir/program/../program/libchartcorelo.so(_ZN5chart18WrappedPropertySet16setPropertyValueERKN3rtl8OUStringERKN3com3sun4star3uno3AnyE+0x94d)[0x7f126eaaf18d]
> ~/lo/core/instdir/program/libxolo.so(+0x3095784)[0x7f1536542784]
> ~/lo/core/instdir/program/libxolo.so(+0x30841ac)[0x7f15365311ac]
> ~/lo/core/instdir/program/libxolo.so(+0x3070384)[0x7f153651d384]
> ~/lo/core/instdir/program/libxolo.so(+0x3066b7a)[0x7f1536513b7a]
> ~/lo/core/instdir/program/libxolo.so(+0x305afe9)[0x7f1536507fe9]
> ~/lo/core/instdir/program/libxolo.so(+0x30bf94a)[0x7f153656c94a]
> ~/lo/core/instdir/program/libxolo.so(+0x30c005b)[0x7f153656d05b]
> ~/lo/core/instdir/program/libxolo.so(+0x36a5b0f)[0x7f1536b52b0f]
> ~/lo/core/instdir/program/libxolo.so(_ZN11SvXMLExport9exportDocEN6xmloff5token12XMLTokenEnumE+0x520f)[0x7f1536b59acf]
> ~/lo/core/instdir/program/libxolo.so(+0x30bd328)[0x7f153656a328]
> ~/lo/core/instdir/program/libxolo.so(_ZN11SvXMLExport6filterERKN3com3sun4star3uno8SequenceINS2_5beans13PropertyValueEEE+0x18fa)[0x7f1536b445fa]
> ~/lo/core/instdir/program/libxolo.so(_ZN11SvXMLExport23ExportEmbeddedOwnObjectERKN3com3sun4star3uno9ReferenceINS2_4lang10XComponentEEE+0x1b1b)[0x7f1536b70c2b]
> ~/lo/core/instdir/program/../program/libswlo.so(+0x113d7e74)[0x7f14f0601e74]
> ~/lo/core/instdir/program/libxolo.so(_ZN22XMLTextParagraphExport18exportAnyTextFrameERKN3com3sun4star3uno9ReferenceINS2_4text12XTextContentEEENS_9FrameTypeEbbbPKNS4_INS2_5beans12XPropertySetEEE+0x2a7b)[0x7f1538095cab]
> ~/lo/core/instdir/program/libxolo.so(+0x4c1869c)[0x7f15380c569c]
> ~/lo/core/instdir/program/libxolo.so(_ZN22XMLTextParagraphExport28exportTextContentEnumerationERKN3com3sun4star3uno9ReferenceINS2_9container12XEnumerationEEEbRKNS4_INS2_4text12XTextSectionEEEbbPKNS4_INS2_5beans12XPropertySetEEE7TextPNS+0x3564)[0x7f1538068404]
> ~/lo/core/instdir/program/libxolo.so(_ZN22XMLTextParagraphExport26exportTextRangeEnumerationERKN3com3sun4star3uno9ReferenceINS2_9container12XEnumerationEEEbbRb+0x268e)[0x7f153807413e]
> ~/lo/core/instdir/program/libxolo.so(_ZN22XMLTextParagraphExport15exportParagraphERKN3com3sun4star3uno9ReferenceINS2_4text12XTextContentEEEbbbR22MultiPropertySetHelper7TextPNS+0x78dd)[0x7f15380717ad]
> ~/lo/core/instdir/program/libxolo.so(_ZN22XMLTextParagraphExport28exportTextContentEnumerationERKN3com3sun4star3uno9ReferenceINS2_9container12XEnumerationEEEbRKNS4_INS2_4text12XTextSectionEEEbbPKNS4_INS2_5beans12XPropertySetEEE7TextPNS+0x1fa8)[0x7f1538066e48]
> ~/lo/core/instdir/program/libxolo.so(_ZN22XMLTextParagraphExport10exportTextERKN3com3sun4star3uno9ReferenceINS2_4text5XTextEEEbbb7TextPNS+0x153e)[0x7f15380647ce]
> ~/lo/core/instdir/program/../program/libswlo.so(+0x111c0fe6)[0x7f14f03eafe6]
> ~/lo/core/instdir/program/../program/libswlo.so(+0x111b8269)[0x7f14f03e2269]
> ~/lo/core/instdir/program/libxolo.so(+0x36a6969)[0x7f1536b53969]
> ~/lo/core/instdir/program/libxolo.so(_ZN11SvXMLExport9exportDocEN6xmloff5token12XMLTokenEnumE+0x56e9)[0x7f1536b59fa9]
> ~/lo/core/instdir/program/../program/libswlo.so(+0x111aeb7b)[0x7f14f03d8b7b]
> ~/lo/core/instdir/program/libxolo.so(_ZN11SvXMLExport6filterERKN3com3sun4star3uno8SequenceINS2_5beans13PropertyValueEEE+0x18fa)[0x7f1536b445fa]
> ~/lo/core/instdir/program/../program/libwpftwriterlo.so(+0xeebe7d)[0x7f126370ee7d]
> ~/lo/core/instdir/program/libsfxlo.so(_ZN14SfxObjectShell8ExportToER9SfxMedium+0x3761)[0x7f156abb6e01]
> ~/lo/core/instdir/program/libsfxlo.so(+0x4f0df53)[0x7f156aba5f53]
> ~/lo/core/instdir/program/libsfxlo.so(+0x4f40bbf)[0x7f156abd8bbf]
> ~/lo/core/instdir/program/libsfxlo.so(+0x4f391d6)[0x7f156abd11d6]
> ~/lo/core/instdir/program/libsfxlo.so(+0x4ea079b)[0x7f156ab3879b]
> ~/lo/core/instdir/program/libsfxlo.so(+0x50c00a1)[0x7f156ad580a1]
> ~/lo/core/instdir/program/libsfxlo.so(_ZN12SfxBaseModel10storeToURLERKN3rtl8OUStringERKN3com3sun4star3uno8SequenceINS6_5beans13PropertyValueEEE+0xc28)[0x7f156ad5e9b8]
> ~/lo/core/instdir/program/libsofficeapp.so(+0x9367b9)[0x7f157de6d7b9]
> ~/lo/core/instdir/program/libsofficeapp.so(+0x9ad063)[0x7f157dee4063]
> ~/lo/core/instdir/program/libsofficeapp.so(+0x80f5eb)[0x7f157dd465eb]
> ~/lo/core/instdir/program/libsofficeapp.so(+0x808973)[0x7f157dd3f973]
> ~/lo/core/instdir/program/libsofficeapp.so(+0x8028c9)[0x7f157dd398c9]
> ~/lo/core/instdir/program/libvcllo.so(+0x755d5ee)[0x7f15472b35ee]
> ~/lo/core/instdir/program/libvcllo.so(+0x7544831)[0x7f154729a831]
> ~/lo/core/instdir/program/libvcllo.so(+0x752f77f)[0x7f154728577f]
> ~/lo/core/instdir/program/libvcllo.so(+0xad7adb3)[0x7f154aad0db3]
> ~/lo/core/instdir/program/libvcllo.so(_ZN14SvpSalInstance12ProcessEventEN16SalUserEventList12SalUserEventE+0x682)[0x7f154ab8f5a2]
> ~/lo/core/instdir/program/libvcllo.so(_ZThn40_N14SvpSalInstance12ProcessEventEN16SalUserEventList12SalUserEventE+0x1b3)[0x7f154ab8fd33]
> ~/lo/core/instdir/program/libvcllo.so(+0x9991ac3)[0x7f15496e7ac3]
> ~/lo/core/instdir/program/libvcllo.so(_ZN16SalUserEventList18DispatchUserEventsEb+0x1772)[0x7f15496e7262]
> ~/lo/core/instdir/program/libvcllo.so(_ZN14SvpSalInstance7DoYieldEbb+0x5f0)[0x7f154ab94420]
> ~/lo/core/instdir/program/libvcllo.so(+0x9df4da2)[0x7f1549b4ada2]
> ~/lo/core/instdir/program/libvcllo.so(_ZN11Application5YieldEv+0x18)[0x7f1549b49ec8]
> ~/lo/core/instdir/program/libvcllo.so(_ZN11Application7ExecuteEv+0x103f)[0x7f1549b49aff]
> ~/lo/core/instdir/program/libsofficeapp.so(+0x7fc24d)[0x7f157dd3324d]
> ~/lo/core/instdir/program/libvcllo.so(_Z10ImplSVMainv+0xaea)[0x7f1549be756a]
> ~/lo/core/instdir/program/libvcllo.so(_Z6SVMainv+0x11)[0x7f1549bef981]
> ~/lo/core/instdir/program/libsofficeapp.so(soffice_main+0x76b)[0x7f157df1937b]
> ~/lo/core/instdir/program/soffice.bin[0x308bbd]
> ~/lo/core/instdir/program/soffice.bin[0x308b97]
> /lib64/libc.so.6(__libc_start_main+0xd5)[0x7f157cfd0b75]
> ~/lo/core/instdir/program/soffice.bin[0x25030e]
Comment 1 Vasily Melenchuk (CIB) 2021-08-20 06:56:48 UTC
Confirmed with master. Looks like another case when frame format has no name, thus undo/redo can't work correctly (what is happening during epub export).

Can be reproduced in LibreOffice (with --enable-dbgutil) without conversion: just move/modify diagram in LibreOffice.
Comment 2 Xisco Faulí 2022-05-03 12:26:04 UTC
Dear  Vasily Melenchuk (CIB),
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assign it back to yourself if you're still working on this.
Comment 3 Commit Notification 2022-08-03 15:58:47 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4d6243693c228703394c00164276f8326447beb9

tdf#143703 sw: always assign name for fly section

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Michael Stahl (allotropia) 2022-08-03 16:55:59 UTC
should be fixed now
Comment 5 Commit Notification 2022-08-04 23:26:40 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "libreoffice-7-4":

https://git.libreoffice.org/core/commit/d0a8f6857e93f1f4a26f05615618ff733bfb4851

tdf#143703 sw: always assign name for fly section

It will be available in 7.4.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2022-08-04 23:27:52 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/679e3e050e4b08bfad335b86d23572518d82ff34

tdf#143703 sw: always assign name for fly section

It will be available in 7.3.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.